I have bought a Samsung I9070 Galaxy S advance. Whenever I enter Play Store (Google Play Store Version 3.4.7), it displays waiting sign and then Connection Time Out Error is shown. I use mobile data connection to access the network. Please help me to solve this asap

Phone Details:

Device: Samsung Galaxy S Advance
Android Version: 2.3.6
Baseband version: I9070DDLI1
Kernel version: dpi@DELL163#2 SMP PREEMPT Thu Sep 13 22:11:28 KST 2012
Build Number: Gingerbread.DDLI1

  • 1
    Can you browse to websites via the browser successfully? Can you browse secure (https) sites via the browser? Can you use other Google account applications (like GMail)?
    – P.T.
    Commented Nov 3, 2012 at 20:28
  • Yes, I have the same problem. Just bought a new Galaxy S Advance, 2.3. I'm not able to download any app. I tried to clean the cache and fix the time, doing a factory reset but nothing helped. I think the cause is that my same gmail is linked with my old Android phone as well as this new one. Now I'm going to upgrade to ICS version soon, hope that will help me. Good Luck
    – user35844
    Commented Jun 14, 2013 at 10:14
  • Same issue on a Colours ShineII. Commented Sep 8, 2013 at 14:16
  • I have the same issue. I have try everything in this post but nothing has worked so far.
    – dandaman12
    Commented Mar 20, 2014 at 19:55

3 Answers 3


I had the same problem after upgrading my Android version. I fixed it by clearing the Google Play store cache and data. Go to Menu Settings > Applications > Google Play Store and click the Clear cache button and Clear data button.

  • That didn't work for me on a Colours Shine II. Commented Sep 8, 2013 at 14:20

Make sure date and time are correct.

That will more than likely fix your problem.


Go to settings-> mobile network -> access point name Try the one without the proxy.

It may resolve the issue.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .