I have a x86 system (Asus Eee Pc)having hard disk of 232 GB, in which 4 GB allocated for Android and rest I don't know where it is gone. If I open super user and running this command in android terminal: cat /proc/partitions I get following result:

Block_Size(232Gb) sda
Block_Size(4Gb) sda1
Block_Size(rest) sda2

This shows there are two partitions (sda1, sda2) of total 1 drive (sda). Android is installed in sda1 and seen in it's file system. But sda2 data is invisible. When i run mount command , we get :

  • rootfs /rootfs rw 0 0
  • proc /proc proc rw ,relatime 0 0
  • /dev/sda1 /mnt ext3 rw,relatime,error=continue,barrier=0,data=writeback 0 0
  • few lines .... But nothing about sda2 .

I also try #busybox fdisk -l /dev/block/sda

   Device Boot     start   End     Blocks  Id  System
  • /dev/block/sda1 1 528 4241128+ 83 Linux
  • /dev/block/sda2 529 30396 23914716 83 Linux
  • /dev/block/sda3 30397 30402 42714 ef EFI(FAT-12/16/32)

And when i run

-#busybox fdisk -l /dev/block/sda2 result is : - doesn't contain a valid partition table .

How can I mount this drive in android? I just want to access and view the sda2 storage drive.

  • Not the final answer, but did you try the mount command (without options) in the same place? It should show you what partitions are mounted in the system and where. It's quite possible sda2 might be listed there, which makes the second part of your question (how to mount it) obsolete, and you can go directly to explore it with your favorite file manager. – Izzy Nov 6 '12 at 7:39
  • hi Izzy , i try mount command but there is /dev/sda1 but not sda2 . – i_max 77 Nov 6 '12 at 8:35
  • That was not clear from your question. It could very well be that the remaining disk space is not even formatted (i.e. has no file system) -- again, your question gives no clue to that. Maybe you add a few more details, e.g. which device it is, which Android version, etc.? – Izzy Nov 6 '12 at 11:54
  • It;s android 4.0 version . Then why it show sda1,sda2 on running command .If it's un-partition how we partition it ? – i_max 77 Nov 6 '12 at 12:41
  • I did not say "un-partition", but sda2 might have no file system (and thus cannot be mounted). Plus you still missed to name your device. Is it a phone, tablet, or x86? – Izzy Nov 6 '12 at 13:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.