Let's see if anybody can help me, because I'm pretty stuck with this.

I've tried to install the following ROM from xda-developers in a Sanei N10:

Unofficial CyanogenMod 10 for many AllWinner A10 tablets

I've installed it following the usual procedure:

  • Press Vol+ and Power to get the Recovery menu
  • Select Wipe data/factory reset
  • Select Wipe cache
  • Install the three ZIP files: "cm10_a10_20120913.zip", "gapps-jb-20120726-signed.zip" & "n10_compatibility_1.2.1.zip"

The problem is, even though the first ZIP with the ROM installs successfully, the second one (the one with Google's apps) refuses to install, showing instead the message "signature verification failed". The same happens with the third ZIP (N10 compatibility).

So the installation doesn't actually finish. If I reboot the tablet, it runs Cyanogenmod 10, but the touchscreen doesn't work (I have to plug a USB mouse to interact with the operating system).

So what do I do to avoid the dreaded "signature verification failed" message? Just in case if it's of any help to identify the problem, I'll mention that I can see the Android bot laying down with a red triangle with an exclamation when entering the Recovery menu.

I've tried to use the ROM Manager which is preinstalled with Cyanogenmod 10, but when choosing "Flash ClockworkMod Recovery" it says that "The SD Card needs to be mounted to use ROM Manager". Of course my MicroSD is properly mounted (I can see its files in the card from console, from the "Terminal Emulator"). I think this happens because the MicroSD is mounted in /storage/sdcard1 instead of in /storage/sdcard0, but I can't change that. I can't download APKs from the browser, either, because it also says something similar about not being able to access the SD (even though it's correctly mounted and I can see it mounted from Settings > Storage).

I've also tried the CyanogenMod A10 ROM available in this page, which is more recent (October instead of September): http://www.slatedroid.com/topic/3870...mod-10-tweaks/ But the same happens.

I've even tried installing the CWM Recovery ROM, but it doesn't let me installing that from the Recovery either (same message about the "signature"), and with Odin3 it doesn't work either because I don't know how to reach the "download mode", which is needed for Odin3. Pressing Vol+ and Power I get the Recovery, but not the Download mode. Does anyone know how do I get to the download mode in the Sanei N10?

Any idea about how to solve this? Right now I have a tablet with no touchscreen and not even Google applications (so I don't even have the Play Store), so it's practically worthless (at least the WiFi works). How can I get this tablet back to being usable?

  • As nobody had any idea yet, I provide my thought even though not sure it helps: You might want to try to symlink your SD to its common place, e.g. ln -s /storage/sdcard1 /mnt/sdcard (in case /mnt/sdcard does not exist). Not sure, but I could imagine some apps looking there to determine whether it is available. Of course you need to do that as root.
    – Izzy
    Nov 8, 2012 at 12:10
  • If that really is the signed gapps package, then I'd guess it's corrupt and you should re-download. I've never seen this error with a signed package otherwise. Nov 8, 2012 at 17:05
  • Thanks for your replies. I tried creating that symbolic link, but it just says "link failed Read-only file system" (I was root, by typing "su" and clicking "Allow" in the Superuser window). So, I can't create symbolic links even while being root user?
    – OMA
    Nov 8, 2012 at 23:58
  • About the gapps package, I already tried downloading it again twice, but I still got that signature error message. But now I've tried downloading a more recent gapps package (gapps-jb-20121011-signed.zip) and that package finally worked! BUT, even though it apparently installed successfully, I still can't see any Play Store icon, nor any other Google app (Gmail, etc.). Why? Those icons should appear after installing gapps, shouldn't they? Maybe this newer "gapps" package is somehow incompatible with this tablet? (is this even possible?).
    – OMA
    Nov 8, 2012 at 23:58
  • Also, even though I can now install the newer "gapps" package, I still can't install the "n10_compatibility_1.2.1.zip" file (I still get "signature verification failed" for that ZIP), which, I guess, contains the drivers needed for the N10 so the touchscreen works (currently it doesn't, and I have to use a USB mouse to use Android in this tablet). Any ideas? I'm getting tired of trying 9485738489754935627 things with no good result :-(. I guess Android is showing here its Linux roots...
    – OMA
    Nov 8, 2012 at 23:59

2 Answers 2


Well, at last I could finally solve the problem thanks to chris5s from the xda-developers.com forum.

These are the steps that worked for me:

  1. Download the latest ClockWorkMod for Allwinner A10 tablets from here: http://forum.xda-developers.com/showthread.php?t=1802268

  2. Put all three files in the ZIP inside the root of a MicroSD card and insert it in the tablet

  3. Check from the Terminal app inside the tablet to see if the MicroSD card is mounted in /sdcard (just type "ls /sdcard").

  4. If the "ls" command doesn't show anything (that's what happened in my case), then you must modify the "install-recovery.sh" file and replace all instances of "/sdcard" with "/mnt/extsd".

  5. With the proper "install-recovery.sh" file, run the commands specified in the above xda link (in my case the card is in "/mnt/extsd" instead of "/mnt/sdcard" as the original example shows):


cd /mnt/extsd

sh install-recovery.sh

sh reboot-recovery.sh

The tablet will then reboot to CWM recovery. Then follow the regular steps to install Cyanogenmod (wipe plus install ROM + GApps + Compatibility). This time the Recovery menu won't care about the files being unsigned and will install them right away!

I hope this helps somebody else!


Just make sure that your build no. of build.prop in update.zip Matches with ur current one. This has helped sometimes.

  • What does Signature verification has anything to do with device properties under build.prop?
    – Firelord
    Nov 16, 2015 at 3:06
  • 1
    @Firelord he probably means the assert props which are included by some developers to perform a device-compability check before flashing. Those lines search for the model number of the device and compare it to the supported ones. But this answer needs some explanation - it's to vague as it is of now.
    – benjamin
    Nov 16, 2015 at 8:35
  • 1
    @benjaminS, yes, thanks for explaining but I already know that, that's why I simply wrote what does Signature verification has anything to do with that. The verification is about authenticity of the file and is not related to device properties.
    – Firelord
    Nov 16, 2015 at 15:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .