Whenever I try to click "upgrade", my phone suddenly disconnects from Kies but the download prompt still runs. After the download process completes, Kies suddenly closes and there are no changes with my phone.

  • 1
    Try putting you phone in Download Mode and try again. – Matthew Read Nov 10 '12 at 6:58
  • There are quite a few samsung-kies questions here, and many of them have to do with update issues. Have you checked to see if any of them are similar to your issue? – ale Nov 10 '12 at 19:08
  • Are you running the latest version ok kies? – Liam W Nov 10 '12 at 19:25

If the answer to my comment is No, then update Kies, and try again.

If the answer to my comment is yes, then try the following:

  • Place your phone manually into download mode, and attempt the update again.
  • Kill all Kies processes using the task manager, and then open the program again.
  • Ensure your USB cable and USB port are working properly (sometimes a weak connection can cause issues)
  • Erase all the data on your android (do a factory reset) and try again (I put this last, as you lose all your data, so should only be tried AFTER you have tried everything else you can think of).
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.