I have a rooted Samsung Galaxy S 2, and last night I updated it to Jelly Bean in hopes that it might solve a few small bugs.

Most everything seems to be working as hoped. However, one new inconvenience has popped up. Before the upgrade, I controlled my MP3 player, Poweramp, by pressing the button attached to the wire of my headphones. One short press to stop and start songs, one long press to advance forward.

After upgrading, whenever I press the button, the phone goes into voice search mode. That is, it turns on the microphone and is waiting for me to say something to search for using the Google search app.

I have tried to look in system settings, and also in the settings for the Google search widget that's on the top of every screen. However, I can't find any way of turning this off.

I want to give priority to Poweramp so that I can control music playback. How do I get voice search to stop getting in the way?

5 Answers 5


I do not know of a way to disable Google Now intercepting media button presess unless you have a rooted phone, as you did not specify that you did, I am going to assume you don't.

The easiest way to do this would be to disable the Google Voice search app.

Go to your Apps settings menu (System Settings --> Apps).

Slide to the left until you get to the 'All' list, scroll down until you find the app named 'Google Voice Search', click it and click the disable button - now reboot your device.


As you have a rooted phone, you could install the Auto starts app from Google play, and use it to disable the 'Media Button Pressed' entry under Google Voice Search.

This is a paid app.

Google Voice Search will not act as if it is not installed onto your device.

  • I downloaded and installed Autostarts, and there is a "Media Button Pressed" entry, but I have discovered that it is not clicking the button once that activates Google Voice Search, it is holding down the button. Holding down the button should cause PowerAMP to advance forward one song. Unfortunately I can't find any entry for long presses on the headset button.
    – Questioner
    Nov 13, 2012 at 8:22
  • Did you disable that entry? It is the same call.
    – Liam W
    Nov 13, 2012 at 8:24
  • There is no Google Search entry under the "Media Button Pressed" Category in Autostarts.
    – Questioner
    Nov 13, 2012 at 8:25
  • OK. In this case, the Google apps is directly intercepting the call, which shouldn't be allowed to happen. I suggest you disable the app.
    – Liam W
    Nov 13, 2012 at 8:27
  • Disable which app, exactly?
    – Questioner
    Dec 3, 2012 at 6:43

Same problem, I have found a solution:

  • Go to Settings > ApplicationManager
  • Slide right to all apps, then find the application called Google Search.

If you have two separate applications installed (in my case), with this name just tap the one with the Google logo (mine was blue.) Then tap uninstall updates and then hit disable. When you now hold the button nothing appears.


In order for this to work for me on Android 4.3.1, I needed to actually Disable the Google Search feature. I know this breaks other things but until there is an option to turn this bug off - and it is a bug if you ask me and in no way a feature, where you are required to do MORE to enact a simple thing that should be accessible out of the box, so to speak - then I will live without this.

Uninstalling the update and reverting back to factory did not prevent the headphone button from going to Google Now. But disabling the Google Search feature, gives me back control over the headphone buttons.


MIGHT BE THE ANSWER: This Google Voice Search pop up appears to be a bug in the Huawei Ascend Y300 model. From This thread on Android Forums that you are not alone with the issue but there is no resolution in the thread.


Thanks for all the helpful attempts to answer. This problem ended up being solved by updating to Android 5.0. Or at least, at some point up to or after upgrading this problem went away, so it could have also been an update to the Google App.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .