I was pretty excited to hear Android 4.2 brings lock screen widgets. But after updating my Nexus 7 tablet, I'm not able to do that: I just have a clock widget that I can remove (it reappears after sleep/wake), but I can't add any widgets in any way. At first I was able to swipe right and I got a "+" where I presumably could add them, but now that's gone.

Could it be because I have a corporate (i.e. exchange) account configured and because that forces me to have a password? Or is it some glitch? I have tried rebooting it.

5 Answers 5


I have the same issue, N7 with 4.2 with an Exchange Corporate Account that forces a password/pin.

You are correct that it has to do with corporate account. I removed my corporate account and was able to add widgets, even with the security still set to "password to unlock". I also changed to Pin and Slide to unlock and all of them worked as well.

I then re-added my corporate account and the widgets that I added were gone and I was unable to add any others.

That said it's not a huge issue for me as the only Widgets I had the option of adding were Clock, Gmail Inbox, and Calendar. Clock is already there and I don't want my Email/Calendar displayed without unlocking the tablet.

  • 1
    Same here. I have added a second user to the tablet, who does not have a corporate exchange account, and that user is able to add lock-screen widgets freely.
    – offby1
    Nov 14, 2012 at 20:48
  • Yup, it's probably because adding a corporate account makes the Email app a device administrator, and that restricts widgets on the lock screen (not just having a password). I wonder what will happen if I add a separate tablet account (Settings > Users) for my work stuff.
    – Felix
    Nov 15, 2012 at 7:44
  • Felix: a brilliant idea! I just set it up myself. I was pleasantly surprised that I could use the same google account for both tablet accounts (I turned off sync on the second one).
    – offby1
    Nov 19, 2012 at 2:52
  • In case anyone is wondering -- I did the above. I have two tablet accounts now -- one for personal stuff, one for work. When I select the personal one on the lock screen, I can add widgets.
    – Felix
    Jan 3, 2013 at 12:42

I have Nexus 7 and now have JB 4.2.

Same problem with no additional widgets being visible, just the "+" box which does nothing if double tapped, held, dragged etc. But I do NOT have a corporate account, as this N7 is my own personal device. I bought the N7 from Google direct, a couple of months ago.

I use Go Launcher EX but this is not the culprit either as disabling it made no difference. Not happy!

Update! Cracked it! Disable screen lock PIN (set it to 'slide to unlock'). Next attempt at unlock and I can now access three widgets (only! which is not impressive). I can now choose from Gmail, Calender and clock. I selected calender. Slide to unlock. Re-enabled 'PIN to unlock' in my settings menu, and relocked the screen. Now I have Clock still as my first screen and slide left to right gives me calender, with a further slide giving me an other "+" which again does not allow additional widget, because I have 'PIN to unlock' enabled.

  • 2
    I have a pattern unlock, so when I press the + to add a new item, it highlights the pattern area for me to unlock the device before adding a new item.
    – cjk
    Nov 15, 2012 at 9:02

In my case, running 4.2.1 on a Nexus 7, I started with calendar, clock and '+' widgets on the lock screen. I can scroll between these with a swipe.

Holding down on a widget shrinks it and brings in an 'X Remove' at the top of the screen; dragging the widget to it drops it from the lock screen. (This does not require authentication.) Removing the last widget will leave me with just the '+' until I cycle to sleep and then back to the lock screen again, where the clock widget now reappears.

Scrolling to the '+' widget and pressing it makes it ask for my unlock pattern, and then displays the available widgets to add, which for me are just clock, calendar and gmail. I'd certainly be interested in hearing about where to get others (in particular, a clock that displays UTC and something to do a better display of my "If found, return to..." information.)


This has to do with the accounts policies and it's not related to a specific device or version (so far). I have the same limitation on my Galaxy Nexus running 4.2.2, so don't expect that update to fix anything.

Actually, since the policy is enforced by the corporate account, we shouldn't see this as a problem but instead as an acceptable limitation. If you have a corporate account set on you phone you shouldn't be able to add widgets because if you can, anyone else could simple add another Calendar or Email (or some third party) widget and have access to the corporate data.


Android 4.2.2 fixes this problem - having a PIN lock code will allow adding widgets by pressing the "+" icon - it'll ask for a code and proceed to the add widgets screen.

  • 1
    Do you have a source for this information?
    – znewman
    Feb 12, 2013 at 20:36
  • I may have just jumped to this based on other things in 4.2.2 working, but it personal experience shows it working for me. Sorry I can't provide more than that!
    – hakusaro
    Feb 14, 2013 at 3:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .