I am using rooted LG P500 running stock 2.3.3. Recently I partitioned my SD card using ROMManager in to three partitions (swap, ext and usb storage). I checked with Mini Partition Tool and understood that the sd-ext type is ext3. Link2SD created mount script and linked apps perfectly, releasing loads of space in memory.

To try an unofficial CM10 ROM, I backed up using ROMManager (NAndroid) and installed the unofficial CM10 ROM. While using CM10, I wiped sd-ext partition and linked few apps with belief that backup is done. Since I was unhappy with the CM10 ROM I decided to restore the backup and while doing so only I observed that my sd-ext partition contents were not backed up.

Thinking that I might not have backed up properly, I tried again to back up in restored backup of stock 2.3.3 and observed a message:

"Could not mount sd-ext. sd-ext backup may not be supported on this device. Skipping backup of sd-ext"

Had if I had noticed this message, I would not have installed the CM10 ROM at all.

Question: How can I make ROMManager to backup sd-ext partitions as well? I guess just because it was unable to mount, it just skipped sd-ext backup. When Link2SD was able to mount, what is stopping ROMManager to mount it and how can I fix it?


  1. I tried this with ClockworkMod Recovery version and ROMManager version is
  2. I have seen the question "Ext4 partition clockworkmod recovery backup" and this question differs because the partition used is ext3 and was created by ROMMananger itself.


  1. I have seen this modaco forum thread and it just only helped me to come to a assumption that my present recovery version does not support it. I will be glad to confirm it either from any authoritative source or burst the myth if some other user successfully backed up (either with sd-ext.

  2. When I attempted to use "mount and storage -> mount /sd-ext" option in CWM recovery console, I just get "Error mounting /sd-ext!" message.

  • Have you fixed this problem? Nov 21, 2012 at 13:57
  • Not yet. I noticed few XDA threads claim Amon Ra recovery manager can backup sd-ext partition. As of now I haven't tried it yet. I also observed that my Rom manager fails to mount the partition through one of the menu options in recovery mode.
    – Narayanan
    Nov 21, 2012 at 16:51

4 Answers 4


A possible solution is described e.g. in this modaco forum thread. In case of that user, the sd-ext partition got corrupted as it was mounted wrongly by the Android system (he used GPartEd to create his partitions which, regardless of the filesystem created (ext2/3/4, fat32), then were mounted as ext4).

So what he basically did: He factory reset the phone, deleted the partitions on SDCard, recreated them on phone (i.e. not with the card mounted to any PC, but directly on the phone, using CWMs options as far as I understood).

I didn't try that solution myself, as I'm not affected by the problem.

  • Thanks @Izzy, I already saw it and recreated partitions using CWM as described. I posted this question after this attempt only.
    – Narayanan
    Nov 22, 2012 at 4:43
  • Oh. Couldn't know that -- sorry to hear it didn't help in your case. Guess I still leave the answer here in the hope it might prove helpful to others with a similar problem.
    – Izzy
    Nov 22, 2012 at 7:09

My suspicion that ROM Manager doesn't support sd-ext backup is quite confirmed with my experience. While looking for alternatives, I understood that there are these three recoveries available:

  1. Clockwork Mod recovery (CWM)
  2. Amon Ra recovery
  3. TeamWin recovery (TWRP)

I tried the TWRP from its XDA thread and I am glad to inform that it did back up my ext3 partition. Other than this benefit, I have a touch interface which is much easier in par with CMW's user interface.


To backup sd-ext


  1. Device should be rooted
  2. Root Explorer
  3. Brain


  1. Open root explorer
  2. Now go to root>data
  3. The will be a folder names sdext 2
  4. Open it
  5. Copy all the the contents of sdext2 folder and paste it in your sd card

Here it is,now you have a backup of your sd-ext


  1. Copy all the contents which we have backuped in previous steps
  2. Now go to root>data
  3. Now find sdext folder and open it
  4. Now paste all the contents we had copied in the step1

Here it is,we have restored over sd-ext


I Think that CWM is not able to detect sd-ext because it is not mounted as"/sd-ext" but instead as "/data/sd-ext" by link2sd. But I do not know in detail abot Android Working I cant fix it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .