I downloaded and installed Kies in my Windows 7 laptop. (Toshiba Satellite.) I plug the phone in the USB, it is recognized and its storage shows in Explorer. Then I run Kies. It says there is a firmware upgrade available. I click to update. A window shows with a progress bar at the bottom, saying something like "downloading update components."

After the download goes to 100%, Kies just silently dies on the PC, no error messages, its windows just vanish. And nothing happens on the phone. My phone is not rooted, it still has the carrier-provided software, regularly updated via Play. It was bought here in Brazil.

Kies is trhe latest version, I had it check for upgrades. I also disabled the PC antivirus to no avail.

7 Answers 7


Just run the Kies with Administrator permission. For windows 7 right click on the "Samsung Kies" or the "Samsung Kies(Lite)" version and select "Run as Administrator"


I had the same problem, did everything I could think of. Finally last night, I decided to try something different. I ran Kies in "Compatibility Mode for XP SP3" it took forever, left the phone plugged in while I went to bed, woke up this morning with 4.1 finally on it.

I run a Windows 7 Premium Home 64bit. Not sure if this will help with everyone's problems with Kies but hopefully it will help a few people. It's worth a try.

My phone is a Galaxy S III from AT&T. To change to "Compatibility Mode" do the following:

  1. Go to C:\ drive, right click and click on `Explore'.
  2. Go to \Program Files x86, look for Samsung then right click on that folder.
  3. Click on Properties then click the Compatibility tab and choose XP SP3

If you are given the option, select Run as administrator.

I really hope this helps everyone else as it has me.

  • Kies is known not to work proper with Windows 64bit edition, regardless, its a very poorly written piece of software!
    – t0mm13b
    Jan 14, 2013 at 23:14

Had the same problem with a Samsung Galaxy S.

I persisted and left it plugged in while I went on to do something else. When I came back later on the phone screen was all blue and the pc went to sleep:


The app then says it needs to restore from an error but it freezed the same way it did on the initial update attempts.

I managed to get kies working "properly" on a computer with more memory. But it didn't unbrick my phone.

So if it goes silent don't insist. You can try on an other computer but my advice is NOT TO USE KIES.

You can flash the stock roms used in Kies with another application. (If you need I'll give more info when I get home).

  • +1 for the advice to not use Kies, as in my previous comment to another's answer above/below, it can soft-brick handsets, use Odin or Heimdall instead. :)
    – t0mm13b
    Jan 14, 2013 at 23:15

Same problem for me (SGS2 i777) on Windows 7 64bits:

I could fix it by going to control panel=>programs=>programs and features. There is an option called Run programs made for previous versions of windows: click on it, follow the steps, troubleshooting will start and a list of programs will appear, once the list is populated select Samsung Kies lite and select troubleshoot program, select start from there.


I had a similar problem with the previous version of Kies. Every time I started Kies (with or without the phone connected) Kies would show a message that some components needed to be updated, even though I had the latest version of Kies. After selecting OK, Kies would start the update process and after a while just close itself without any warning.

I experimented a bit and I think the problem has something to do with rights on your computer. I noticed that Kies does install the components update properly when run from the administrator account, but strangely not when run from another account even when you tell it to "run as administrator". I thought the problem would be fixed after I ran it in the administrator account, but when I started Kies again under my normal (not administrator) account, the update message appeared again, and again Kies shut itself down during the update. After that I gave up and just selected "cancel" every time the update message appeared.

I upgraded Kies itself this morning to version and now the problem seems to be fixed. The update components message does not appear when I start Kies, but I haven’t tried updating the phone’s firmware yet.


This is only due to the less memory on phone. Try to uninstall some applications and media file from phone memory. Automatically it will work.


Here is the solution:

  1. Get sure that u have enough free space in your internal memory.
  2. Update your samsung kies.
  3. If you had connection problem with USB, download samsung mobile USB device: http://samsung-mobile-usb-device-1-0.soft32.com/
  4. Right click on samsung kies
  5. Use compatibility mode ( windows pack 3)>
  6. Before you start updating: Go to your mobile and turn off music, wifi, bluetoot, gps..as well.

  7. Start updating.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .