I'm trying to setup my APN settings on my Samsung Galaxy Nexus, running Android 4.2.

The APN list is currently empty, and every time I try to add one (menu -> add -> fill out form -> save), nothing new appears.

I'm trying to connect to H2O wireless, when I fill out the instructions, I get a warning saying to enter the MCC and MNC (which H2O says to leave blank), the phone says the MCC and MNC are required, so I add in the MCC and MNC using sumac's instructions. After I add the settings and click save, no new item is added to the list of APNs.

I think that there should be an item already in the list, as others mention the default settings, but there definitely should be an item after I add the APN.

Has anyone else dealt with this before?

People have suggested online to others that it may be a firmware issue.

Please let me know if there is anything else to add, this is the first time I have tried to get help with my phone.

Edit: I've talked to H2O's support, and they said 310/410 should work. They said the problem has been in Android since 4.0.2, and all they can suggest is a hard reset. So now, it doesn't seem to be a problem with my carrier, my phone, or the settings. Has anyone gotten around adding APNs on Android since 4.0.2?

2 Answers 2


Your MCC and MNC are indeed required and must match the MCC and MNC detected by the phone. I recommend using Market Enabler (requires root) to force set them if your phone isn't detecting it properly. (It looks like ME has been removed from the Play Store and is now available here).

  • But even after I added MCC and MNC (that I found online), the APN wouldn't save. Is this because I entered the wrong APN, or should it save either way? Commented Nov 16, 2012 at 10:54
  • @Rhino It should only not save if the MCC or MNC is wrong or not what the pphone thinks is correct. Commented Nov 16, 2012 at 16:00
  • Is there any way to find the MCC or MNC without root? I looked on Wikipedia's list of MNCs, and the numbers that Sumac listed look possible. Commented Nov 16, 2012 at 16:17

Sort of embarrassed to admit this, but I rebooted the phone, and all of the APNs I had added were on the list. Problem solved.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .