11

Just recently I noticed on my Nexus 7 that when I start some apps - and it's not just those allows to have superuser rights - I can briefly see a "red frame" all around the screen area of the app that goes away in a second or maybe a little less.

Does anyone know where this comes from and in particular what it means?

Note: as you probably guessed from the contents, my device is rooted. Also note that it's well possible that one of the installed apps is responsible for this, yet I don;t know which. But I'd like to know.

3
  • 1
    That sounds vaguely like the developer options -- check to see if you've got those enabled.
    – offby1
    Nov 17, 2012 at 2:02
  • @offby1: spot on. Please write it as an answer and I will accept it. Although I cannot tell which exact option caused this, disabling the developer options altogether fixed it. Thanks. Nov 17, 2012 at 2:06
  • 1
    Xposed framework did this on my device. Disabling strict mode in developer options didnt work. Disabling Xposed framework worked.
    – Bolli
    Jan 27, 2019 at 11:43

2 Answers 2

13

This is caused by the strict mode setting under the developer options. It flashes a red border around the screen when anything does a long operation on the main thread.

5

Happened with me also. Uncheck the strict mode setting and then reboot the device. Dont forget to reboot.otherwise the settings' change wont apply.

4
  • 1
    It's unnecessary to reboot the device. I've toggled this setting many times. It takes effect immediately. Mar 1, 2013 at 7:53
  • 1
    It may be neccessary. On my Fairphone with Android 4.2.2 it was only disabled after a reboot.
    – cxxl
    Jan 22, 2014 at 17:59
  • 2
    A reboot was necessary on my Samsung Note Pro.
    – Nick
    Mar 23, 2015 at 22:54
  • 1
    @scott severance : On my phone(MI4i), a reboot was necessary for the setting change to take effect.
    – anotherDev
    Dec 28, 2016 at 13:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .