Someone has reported me that he cannot install or upgrade applications on Google Play. It fails with error RPC:S-5:AEC-0

What does that mean? How to fix this?


6 Answers 6


I found this working answer on Androidcentral: Remove and re-add the main Google account


User @rds has given the correct answer about how to fix this problem, but I can tell you that this issue happens mainly after stopping Google Services Framework (this is a practice that some people recommend in order to be able to get OTAs when delayed to be available for your phone).

I had Android 4.2, but I was trying to get a recently released bug-fixing 4.2.1 update, so I just did this (stop Google Services Framework), but after updating Android and restarting my smartphone, I got that infamous [RPC:S-5:AEC-0] error when trying to get some updates for my apps.

First I tried, unsuccessfully, what @Anthony says. Then I did what @rds says (removing/adding my Google account) and the problem has gone!

Let me add: this is not the first time I get that error, but it is until now that I realize both the reason and the solution, so I'm sharing this with you.

  • I agree. That Android Services Framework was the root cause in my case. I did that clear data for all things Google, uninstalled all updates, removed and re-added Google account but to no avail, until I realized that I blocked various Play Services including Services Framework from start-up using AutoStarts. I simply unblocked them, restarted, and voila! everything came back to normal. What a mess!
    – Firelord
    Commented Sep 11, 2015 at 0:07

Go to Settings>Apps>Google Play Store>Uninstall Updates

Then reboot phone.

  1. Go into SETTINGS
  2. Select Apps (select the 'ALL' tab)
  3. Select 'Google Framework Services' and Clear Data (please only clear data; Do not delete Google Services Framework completely)
  4. Select Google Play and Clear data there too (the same process as above)
  5. Reset your tablet by switching on and off

Try resetting your home router just to be on the safe side.

  • 1
    Didn't work for me sadly. Commented Jun 26, 2013 at 14:52

The server error RPC:S-5:AEC-0 can be worked around by going to the 1Mobile App Market and downloading free apps only via that service. Not ideal, but at least it's enabled me to get BBC News, BBC Media Player and Skype.

I've done a fair bit of searching and just can't find an answer for this server error problem.

The SO-question Android error while retrieving information from server 'RPC:s-5:AEC-0' in Google Play? might provide some help. Several of the answers suggest removing and then re-adding your Google account to the Play Store will fix the issue (a reboot may be required).

A similar advice can be found at AndroidCentral:

added my second Google account. I then went to the Play Store > [MENU] Accounts and selected the new account I had added, followed by switching back to the previous account. This resolved the issue for me.

Alternatively it's just waiting for Google to fix the issue.


I have this issue with my tablet and found that saving all my important info and factory resetting the tablet. once I had done this I set up a new g-mail account. so basically starting a fresh. this worked and did not show the error msg any more (RPC:S-5:AEC-O). HOPE THIS HELPS

  • 2
    This is a really extreme solution. It certainly works, but is probably the thing to do if everything else failed
    – rds
    Commented Dec 2, 2012 at 20:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .