Recently I've been having all sorts of troubles with audio and GPS and the compass... I tried different ROMs, different kernels, different patches.

The short story is that after a long time spent messing around trying to get all features working at the same time, in the end I had to factory reset my phone and start anew.

Now, the current situation is that I have a rooted phone running Jelly Bean 4.1. It's freshly installed as of about an hour before writing this.

However, the GPS is unresponsive. Of course I want to fix this, but I don't want to go through the whole mess I just went through over the last few days.

So... how do I get my GPS working without playing feature whack-a-mole? I'm taking a breath, slowing down, and I'm looking for a reliable patch or process that I can execute with reasonable assurance and no guesswork.

Specifics are that I have a Samsung Galaxy S2, GT-I9100, issued in Japan. Android version 4.1.2, Kernel 3.0.15-CM (Siyah 5.0.1), Cyanogenmod 10-20121120-NIGHTLY.

Update: The compass issue I mentioned earlier was fixed when I used the build of Cyanogenmod available in this thread on the XDA forum. So I'm now just focused on fixing the GPS.

5 Answers 5


Have you tried GPSFix kind of apps from Play store?

And take a look at web site Samsung Galaxy S2 GPS Problem? SOLVED! which talks about how a battery saving option (disabling repetitive polling of GPS data) causes fix issues and how it can be tweaked using another app, GPS control for SGS2 which is mentioned there.

Before starting with these two, just for ruling out false alarms, can you try getting a fix with your Internet connectivity on and in open place where you can see sky like in fields?

All said and done, I still do not know why magnetic north is flipped in your case!

  • Thank you for responding. I've tried a variety of GPS fix apps, and testing in wide open spaces, and I still get nothing. A friend of mine has Jelly Bean installed with no GPS issues, so I think GPS should work with this ROM, but so far, no joy.
    – Questioner
    Nov 21, 2012 at 15:40
  • Ended up getting an answer elsewhere, but 100 rep to you for at least trying to help. :)
    – Questioner
    Nov 26, 2012 at 3:12

I found a solution in this answer in the XDA forum.

To generalize and hopefully be of use to others, the key point seems to be that even if you think you have the right ROM for the right device, it might be that your particular model has very slight differences.

In my case, if I understand correctly, I was using ROMs built for the GT-I9100 model of the Samsung Galaxy S2. However, the device issued in Japan, the SC-02C, has some very slight differences. So, I needed to get be more particular about which software I downloaded.


Does the GPS work with the stock ROM of your mobile? If yes then the problem seems to come from CM.

If Jelly Bean is not available as stock ROM for your mobile it is likely that the GPS will not work with CM Jelly Bean because then the necessary drivers are likely to be missing.

  • Please ellaborate more your answer, make it more clear, I couldn't understand what was your question about the stock ROM. Also, if you want to question something to the author, make it on a comment if possible.
    – Markissimo
    Nov 21, 2012 at 11:51
  • Because of my reputation I'm not able to comment at the moment... I try to make my answer more clear
    – Uwe Plonus
    Nov 21, 2012 at 12:13
  • "If Jelly Bean is not available as stock ROM for your mobile it is likely that the GPS will not work with CM Jelly Bean because then the necessary drivers are likely to be missing." - Not true in my case. I have LG P500 which is only 'officially' blessed with 2.3.3. I had used CM7 (2.3.3 Gingerbread), CM9 (4.0 ICS) and CM10 (4.1 Jellybean) on my device and all had no problem with GPS fix.
    – Narayanan
    Nov 21, 2012 at 12:44
  • 1
    That is possible. Then you're lucky. But not always the drivers from GB work on JB.
    – Uwe Plonus
    Nov 21, 2012 at 12:48

Found it for my SGS2 with JellyBean Rainbox ROM, and read about it on a Nexus forum: you should disable Google Location in settings. Reboot your phone and enable it again. GPS fixes right away now ;-)


A reboot seems to fix the problem reliably, but this is an unacceptable solution.

  • 1
    He has factory reset the phone and freshly installed ROMs on it, I would imagine he had restarted it during this process.
    – Peanut
    Mar 14, 2013 at 18:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .