I have a galaxy tab p1000 I have been trying to upgrade it for 3 days straight now with many tutorials from 2.2 froyo to anything newer but i keep coming back to square one - my old applications keep appearing after flashing/wiping.

It looks like there is some protection on the partitions that doesn't allow me to change/delete data on them.

I tried: restocking using Odin (with the pit and original firmware) recovery mode factory reset + cache + dalvik reset settings -> privacy -> factory reset removing the applications one by one.

Usually it shows me that they are removed but after restart everything returns. Many of the apps (3rd party and google) keep crashing all the time.

Nothing helps. each time i bring up the OS again the old apps appear again. Same happens after connecting to comp and manually deleting stuff - after unmount, they return (everything i deleted).

help ?

  • Do the applications return even if you don't associate the tab with your Google account? There's a setting called something like Automatic restore in Settings -> Backup & reset, you could try disabling this to prevent your previously installed apps from being reinstalled after flashing. – onik Nov 22 '12 at 10:27
  • I can't diassociate my phone from the account - wipes don't do it and when i manually try it from settings then gapps (google framework) crashes and is not removed :( – thedrs Nov 22 '12 at 13:07
  • Is your bootloader locked or something? If the flash and factory reset actually succeeded then there would be no way for the apps to come back. – Matthew Read Nov 22 '12 at 20:07
  • Bootloader is not locked. The flashing changes OS but apps keep staying there. Someone told me it might be related to internal sd memory going bad. – thedrs Nov 23 '12 at 16:05
  • after performing the standard restocking procedure (repartitioning with pit and GB safe v5) everything should be ok, but instead, when i enter recovery i get the following error: --Updating application... E:Can't open directory '/preload/app/'. (No such file or directory) copy application failed. – thedrs Nov 25 '12 at 5:59

If you use recovery to wipe user data, and then wipe your dalvik cache in the advanced settings, then reboot all apps and data will be removed.

Ensure you haven't enabled google restore - when the startup wizard starts, it should ask if you want to restore to this device. Unstick this option.

  • No restore nor backup are marked. Also after wiping all (+dalvik) and booting it will show me the wizard but always remembers previous account and uses it - it wont let me set it on startup. Can't this be a partition mount in Read Only or something like that ? I wish there was a method to really format all user data maybe with odin ? – thedrs Nov 22 '12 at 12:23
  • Maybe i can try to return to stock rom froyo 2.2 ? do you know of a tar out there with this original version ? – thedrs Nov 22 '12 at 13:15

I found the problem in the end... It was a faulty internal flash memory module. After researching the web I found that the p1000 has a common internal memory fault that happens after several years.

I can only say that i also found a tutorial that teaches how to remove (physically) the internal memory chip from the motherboard and changing the rom to know how to leave only on the external sd card.

I tried this technique in many variations but i never manage to make it work. Still stuck with the tablet

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.