Yesterday my HTC Tattoo (with software based on Donut) started giving me "No connection Retry" errors for Gmail, YouTube, Google Reader, Market and anything else that requires sign in with Google credentials.

After doing a "Clear data" on the Gmail app I get another message,

There was a network error while trying to sign in to [email protected]. Retry now or press the back button to cancel

Whatever "network error" there is, does not stop me from using the web browser. Indeed I am able to logon to the mobile (and unfortunately buggy) Gmail web app from the browser. I will note that I get "Security warnings" about the certificate for google.com.au: "the name of the site does not match the name of the certificate" when I logon via the web, although I saw that message months back and have been able to use my apps until now.

Any idea what could have triggered this? I've not changed my google account credentials, or switched SIM card, or done anything that I think could make it my fault.

  • Thanks to those who answered. The problem I noted here actually disappeared when I moved from Australia to Sweden just before Christmas. Just before I took the flight I still had the problem, and on my arrival everything was working again. I can't confirm that it is the case, but it seems plausible that this was an issue related to time/certificate that was solved by the clock auto-adjusting on landing in a new timezone. Commented Feb 24, 2013 at 20:09

5 Answers 5


I've the exact same issue on a Galaxy Tab P1000 with gingerbread 2.3.3 since about 2-3 weeks. My current interpretation is that Google has updated its certs (the current one I get is dated 11/7) and the new ones are not trusted by Android anymore making it impossible to use any google account for mail/play store/etc... If this is the case, the only solution would be an update from the manufacturer or maybe rooting the device and convincing it that the new cert is good.


I had the same problem, and the solution was to set the correct date/time in the phone settings (in spite of 'Automatic' option turned on for network time synchronization, I had 1980 year). So, libit was right about certificate time issue.

Also, take a look at Google Groups thread related to this issue - there are a lot of different solutions, which could also help.


I was encountering the same issue in the last 24 hours or so where I couldn't use any of the Google applications. I tried powering off the phone and everything

Today I used the time-zone guess from the follow up post (also, when I think about it, for some reason my phone switched from 12hr clock to 24 hr clock last night). The issue has been resolved and I can use all apps now. I must have changed the settings inadvertently when the phone was in my pocket or something.


As daft as it sounds make sure your wifi is connected - I got this error & couldn`t figure out why until I realized one of my battery saver apps had switched off my wifi

  • The OP never mentioned anything about battery saver, but then again, the OP is running an old version of Android... xD
    – t0mm13b
    Commented Nov 8, 2013 at 21:12

Guys I found the solution!

Follow the instructions to this link! 100% it'll work though not mine, credits to the owner.


  • Alas, link only answers aren't considered a good fit here, would you mind to elaborate (and edit the answer)?
    – ce4
    Commented Oct 15, 2013 at 19:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .