0

Why when my phone LG GT540 is running and seen by ADB after bootup it disconnects (not from PC just from ADB, as PC still can see it it Device Manager) after few seconds after bootup sequence?

The problem is occuring only with GT540, tested other device - HTC - works fine.

The key could be USB drivers, but tried many of them official and handmade.

Also I've tried running phone in "Recovery" or "Safe" Mode - when LG firmware updated my phone via USB with no major problems with connection, hovewer I cant use ADB over this "Safe" mode, can't I?

4
  • Have you enabled USB Debugging in the Settings?
    – onik
    Nov 27 '12 at 9:46
  • Yes, of course.
    – user24162
    Nov 27 '12 at 9:46
  • What device is it detected as after boot? Mass storage? Generic device? Which Windows version?
    – onik
    Nov 27 '12 at 9:49
  • WIndows 7 64b, i47.tinypic.com/1hufy1.gif (tis undetected device is probably a SD Card)
    – user24162
    Nov 27 '12 at 9:51
0

Some people have had their device turn on the mass storage mode by itself.

Verify that you haven't enabled Mass storage only mode in Settings -> SD Card & storage -> Mass storage only, then reconnect & restart adb daemon.

4
  • Why to restart adb deamon?
    – user24162
    Nov 27 '12 at 9:58
  • To verify it's listening actively on the port.
    – onik
    Nov 27 '12 at 10:02
  • It wont help...
    – user24162
    Nov 27 '12 at 10:13
  • Actually after reboot of PC it worked! Thanx!
    – user24162
    Nov 27 '12 at 10:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.