I have recently learnt a few things about Android and its system. I have a Huawei Ascend Y200, and I flashed it with ClockworkMod specifically for Y200 with a computer and it worked.

I rooted my phone by flashing it and was able to install Superuser.

When checking for swap partition I found out that my ROM doesn't support it. I got ROM Manager it prompted me with a message:

ClockworkMod must be installed, do you want to insall it?

and I mistakenly tapped Yes .

Now I can't get past the bootloader (Huawei logo) - it freezes there.

I tried to reboot into recovery mode by removing the battery and pressing the UP + Power Buttons. I tried reflashing the first ClockworkMod. I was able to see the device on adb lists. I also tried factory reset.

None of this has helped. I still couldn't get my phone to pass the logo (before reflashing)

Further info:

  • I had access to the device's adb somehow. I reflashed it and now I can only see the adb device when in recovery mode and is stated "recovery" beside the device number and can't reflash, or access adb anymore (cmd promt says waiting for device forever).

  • Now that I don't have access to the adb device in bootloader (stuck) image, I can't do anything like reflashing ClockworkMod. Every time I plug it in the cmd prompt says device not found. When the phone is in recovery mode, the process in cmd prompt gets stuck at waiting for device, because now it shows as "recovery" beside the device number in the list, so as the device isn't responding to the process and won't restart as before.

  • Whenever the phone is off, if I plug the USB cable into the phone (with other end connected to PC) it does not charge, and goes directly into recovery mode. I don't see the charging indicator small lamp on.

  • I can press both UP and Down buttons + Power and I get a pink screen. I haven't really got much info about it.

Some, on the internet, say it's a never ending bootloop. And I've heard I can flash it to skip the bootloader screen and go into fastboot, but couldn't find proper instructions and won't be able to flash it anyway (can't see the device anymore unless in recovery mode but device will respond to any process).

I really need help; how can I pass the boot-loader again?

PS: Now, I've learnt that my phone is in boot-loop and needs to be flashed into a new ROM, or maybe get past the boot-loader also by Flashing.

2 Answers 2


I had the same problem with my y200.

  • Go to huaweidevice.com and download the firmware.
  • Extract the folder downloaded and copy it to the SD card.
  • Insert the sd card into the phone.
  • Press vol up & down key at the same time + power button, then a message installing package comes up.
  • Then wait until the phone reboots.

That's how its done


If you can get into the bootloader, you can issue a fastboot -w command which will erase all data - this normally solved boot loops.

If not, you should be able to install a new ROM using the same bootloader (fastboot), you just need the system.img file (make sure you issue a fastboot -w command before you flash, however).

I believe that this pink screen you talk of could be the fastboot/bootloader mode you need to issue the above commands - you just need the fastboot.exe file, as well as the .dll files that come with adb.exe.

  • Yes, I can only reach the first bootloader as there are two, and freeze there. if i connect the phone through usb to the computer (when in frozen bootloader), it won't list the device's adb, and if i ran a batch file to flash it it will say "waiting for device" where the phone is not responding. Now I tried the command " fastboot -w " and it wouldn't do anything as it says " waiting for device " ...
    – MoHackings
    Commented Nov 27, 2012 at 19:30
  • Did you try putting it to the pink screen and using fastboot?
    – Liam W
    Commented Nov 27, 2012 at 19:32
  • you mean the "fastboot" command??.. Trying now, But as i did now, it installed different drivers. and now I tryed it without checking any devices attached, Nothing happenned it also says "waiting for device".. the device wasn't even attached under adb list.. so it was only prompting it and pending till there's a device responding.. this is the pink screen mode. The other modes does the same now, I can't even see the device's adb even in Recovery mode...
    – MoHackings
    Commented Nov 27, 2012 at 19:42
  • ok there has been a misunderstanding... I now understand clearly how to use fastboot and its a "mode" :) ok, and i can now use fastboot commands, i did clear cache with the command "fastboot -w", but phone still boot loops.. is there anything to do after that? and when i tried to flash a system.img it said "failed (remote: data too large).. so please please just one more step ahead :p inform me with any usefull commands or other than that is there a way to flash it when its too large?
    – MoHackings
    Commented Dec 2, 2012 at 22:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .