My wired headphones, the ones supplied by samsung with the Galaxy S, button doesn't answer calls, open music player, play a track, or even pause tracks. But when I downloaded the trial version of powerAMP, the button interacted only with the app. What should I do to make it work with the whole android again?

Mind that I'm running samsung's froyo on a rooted galaxy S handset.

  • What Galaxy S model do you have, and is it an official Froyo release or a leaked version? Dec 17, 2010 at 5:11
  • GT I9000, official froyo release Dec 17, 2010 at 7:40

2 Answers 2


According to this thread you aren't alone:

Poweramp hijacks the headset controls(wired & BT) from all my other media players... I use headset controls with the stock mp3 player, pandora, xiialive, & fm radio.. they all surrender the headset controls when not in use, but when I bring poweramp in the mix the headset controls only work with poweramp.. I went into the headset options in poweramp and disabled everything, that stops the controls in poweramp, BUT doesn't restore the headset controls to the other players when I want to use them...

but according to the last post by the dev this should fix it assuming you are running latest version (uninstalling would probably restore control as well):

Not exactly. I've made today a workaround I mentioned above - so unchecking Headset Buttons option in PowerAMP now should properly redirect next button presses to other players (applies to 2.2 only). This will be included in next minor release, coming beginning of the next week.

Thanks for the report again.

  • Unfortunately, I've tried both things, I've tried bringing PowerAmp off the headset controls and it didn't work. And I tried uninstalling it and it didn't work either. Dec 28, 2010 at 12:49
  • What about clearing PowerAMP's defaults under Android's Settings - Manage Applications? Try clearing the defaults then uninstalling PowerAMP then run another music player. Dec 28, 2010 at 13:34
  • :'( didn't work either Dec 28, 2010 at 14:24

If the bug has been fixed in PowerAmp as ToxMox says, I would try a factory reset. Hopefully that will fix whatever happened to the system and the fixed PowerAmp won't do it again. You can backup everything with ROM Manager or just your apps/data with Titanium Backup (both require root).

Edit: I suppose my final suggestion would be to flash a stock ROM (e.g. this official 2.2.1) through Odin with "Re-partition" checked. Steps:

  1. I recommend using ROM Manager to make a complete backup of your system, then copying that backup to your computer (because Odin will format your phone).
  2. Take out your phone's battery, plug it into USB, and put in the battery while holding both Volume buttons. This will put it into firmware download mode.
  3. Start Odin. If it doesn't see the device, unplug it and plug it back in.
  4. Load the "s1_odin_20100512.pit" file (comes with Odin) in the PIT field of Odin.
  5. Load the downloaded ROM in the PDA field of Odin.
  6. Make sure Re-Partition is checked.
  7. Hit Start.
  8. If Odin fails or it seems like nothing is happening for about 10 minutes or so, try again from step (2). Sometimes Odin is finicky.

This should get you a completely clean system.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .