I want to install an application as a system application.

To do so, I must remount the system partition RW, to do so I run the command adb shell remount rw in a terminal, but I get the error /system/bin/sh: remount: not found.

How can I remount the system partition RW?

2 Answers 2


The command is: adb remount, please try this first. However, if it doesn't work, make sure your device is rooted, and try these commands:

adb shell
mount -o remount,rw /system

Those commands will directly remount the system as RW. However, you must be rooted.


I have faced the exact same issue: "remount: not found". Seems there are different syntax possibilities depending on the OS or updated libs. In case the syntax doesn't suit, it just interprets 'remount' as a command "not found".

Then I tried

mount -o rw,remount /system

and it worked.

The strange thing is, a few months before, just after having rooted my device, this worked: mount -o rw;remount /system. There seems to be also: mount -o remount,rw /system.

Just try different syntaxes. If you rooted your device, one must work.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .