I have a film in the .AVI format, with an SRT subtitle file, and an AC3 audio track.

I used the S/W decoder function.

The film can be played with/without the subtitles, and the AC3 file itself can be played. I have tried MX player (not PRO) with the ARMv7 codec and VPlayer with the ARMv7 codec. I have the same problem on my Nook Color. If I stop the film and try to select audio, I have the only item which means embedded audio track.

  • 1
    Am I assuming correctly that you have 3 files (.avi, .srt & .ac3 (maybe some other language)) which you want to simultaneously play or is the ac3 track embedded in the avi? I'd say: Use handbrake to merge all into a single playable (.mkv or so) file for your handset. – ce4 Nov 29 '12 at 18:36
  • 1
    Thanks for sharing your workaround! If you want, you can compile this into an answer, just FYI. – ce4 Dec 12 '12 at 12:51
  • 1
    Thanks. (PS: The answer section is below... Sorry for nitpicking) – ce4 Dec 12 '12 at 17:31

The solution.

I ended up preferring films in the .MKV format and using mkvmerge for merging audio tracks and subtitles into a video file.


for those who want to watch films with an embedded AC3 audio track, this solution could be useful. It worked on my Samsung Galaxy Tab 4 10.1 SM-T530NU, and I'm sure it would work on any other device.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.