The problem

I am trying to deploy a custom application to an Alcatel One Touch 995 running Android 2.3.6. I using Eclipse to compile the source code and push it onto the phone. The Android Device Chooser within Eclipse starts up and lists a device however it does not recognize the maker or model. The device shows up as question marks for the serial number (see screenshot).

Android Device Chooser showing question marks

I am able to install the application to a Samsung device. I tried the procedure on Windows 7 running Eclipse 3.7.2 and on Ubuntu 12.04. running Eclipse 4.2. The Android Development Kit is up-to-date on both systems.

I enabled "Unknown sources" and "USB debugging" in the application settings.

The USB driver attempt

I found a USB driver from Alcatel. The archive contains driver for different Windows versions. When I try to update the "Android USB Device" in the Windows device manager I am informed that the driver version is up-to-date. Here is a screenshot of the "ALCATEL Dream Composite ADB Interface" properties.

"ALCATEL Dream Composite ADB Interface" properties

It seems as if this attempt was not helpful. I leave it anyways in case someone stumbles into the same situation.

The solutions


Strange! I installed almost all available API Versions in the Android SDK Manager and now also selected the images for ARM, Intel and MIPS. The result is that the device is recognized on Windows.

Android Device Chooser

I tried hard to undo the driver installation on Windows. To me, the most obvious is removing the "Google USB Driver". So I did and restarted Eclipse and the computer but still Windows remembers the maker and model. I further tried to remove other items without success. I will leave my experiments in this question for others to figure out the key installation module needed on Windows to recognize the device. I guess its "Google USB Driver" and the .inf file has been copy to the Windows system folder in the background.


Regarding Ubuntu, I like to grant the answer Flow (please put your comment as an answer). I configured a device rule as it has been explained by vsm and others. There is also an official guide entitled: Setting up a Device for Development.


It could be that when I tried to update the Windows driver with the USB driver from Alcatel that it actually updated my system without telling me. All I received was the message "Driver version is up-to-date". I missed to check the version before I started. If anyone can verify this theory on a "clean" system I happy to hearing from you.

  • I would suggest that this is about development, and is therefore off topic here. I am not 100% sure however...
    – Liam W
    Nov 29, 2012 at 19:36
  • 2
    It seems to me that your question is not "how to install an apk' as you know that, but is instead "Why does adb devices show all question marks and how to fix it?". Please make sure that your questions describe your real problem in the most accurate way.
    – Flow
    Nov 29, 2012 at 20:29
  • 1
    If that happens on Linux the reason is susally that the adb daemon is unable to write to the usb device in /dev. See stackoverflow.com/a/4079361/194894
    – Flow
    Nov 29, 2012 at 20:43
  • @Flow Can you please transform your comment in an answer so I can grant you the answer flag?
    – JJD
    Dec 1, 2012 at 14:48

2 Answers 2


If that happens on Linux the reason is usually that the adb daemon is unable to write to the USB device in /dev. For more information see this answer on stackoverflow.


Have you installed the relevant ADB drivers for your device, and is it in USB Debugging mode?

If that fails, then you could always compile it and copy it to your device, and install it using a file manager.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .