I have an Android Google tablet that will not connect to internet Wi-Fi on Billion 5200n RC model router. iPad and iPhones do connect without a problem, but the tablet shows its connected but when I go to browser it will not load a page and connect to internet. Have tried connecting tablet at the neighbors house and it connected without a problem. Can someone please help me out and tell me what the problem is.

2 Answers 2


Try going to your Billion router and check that it is not restricting access by MAC address. If it is then make sure your Android's MAC address is pluged in.

Also, if you have Bluetooth running on the tablet, try turning it off first, in case there is an address conflict.


I once had a problem with another Wi-Fi client. My device got connected to the router (got a dynamic IP adress from the router), but was not able to browse the web because the DNS was not working. Have you tried wifi analyzer to examine your problem?

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .