The phone is connected via USB to Windows 7 64-bit. The USB debugging option enabled.
When I connect the phone to the computer, I'm notified that some drivers failed to install.

Do I need these for development? Where can I get them? I have yet to try the Kies drivers.
As is, the device is connected as a "media device", which is useless in terms of development.
When trying an Android SDK sample demo, it starts the emulator instead of running on the phone.

More info about device:

  • Model number: SGH-T999V
  • Android version: 4.0.4

edit: See my answer below.

  • 1
    Yes, try the Kies Drivers. That should help. Dec 2, 2012 at 9:12

7 Answers 7


The easiest way to get this driver is from the samsung website. There is a link to a download that installs only the driver (none of the bloat). See https://stackoverflow.com/a/11851697/1427165 for more details.

  • Yes, that's what I did. I updated my question on Dec 3 '12 with the solution but just moved it to its own answer.
    – Dennis
    May 10, 2013 at 4:22

There's no need to install Kies. Download the driver SAMSUNG_USB_Driver_for_Mobile_Phones_v1.5.14.0.exe (or a higher version) which is available from the Samsung website. Click on the Manuals & Downloads tab (below the image of the phone) and then the Software tab.

After installing, I connected the S3 via USB and Windows Update automatically searched for and downloaded a package that was 6.8MB, followed by this notification.

I restarted my computer (just in case) and I can now use the S3 for development, even though it says the device is connected as a "media device".


You need to install the Samsung ADB Driver.

You can install these by installing Kies (they will be installed automatically), or you can download and install the driver here - it says it is for the Galaxy S2, but it should work for all Samsung devices.

Once installed, you may need to reboot your computer, and then connect your device. If that still doesn't work, go into your device manager and delete any unknown devices, or devices with question marks next to them (highlight them, and press the delete key).

Once that is done, plug the device back in and the driver should install. You should then be able to see the device by using the adb devices command.

  1. Uninstall the Samsung Galaxy S3 driver.
  2. Download and update your fingerprint sensor driver. In my case, I use the AuthenTec driver.
  3. Download and update your Bluetooth device driver (i.e. Broadcomm, etc)
  4. Reboot computer.
  5. Re-install the Galaxy S3 driver.
  6. Connect device.
  7. Device will look for software updates and everything should install.

Good to go!


You can try using Universal Adb Driver from this link:



Well, I have tried all these things I could find on the web and my Win 7 professional PC would not recognize my Galaxy S 3....I then realized my new computer has nothing but USB 3.0 ports so I decided to try to use an old USB hub I have. I plugged it into the computer and a driver for it was successfully installed. I then plugged my Galaxy S3 into the USB hub and then the computer recognized it and installed the driver and I can access all the files on my phone. So I can only conclude it is a USB 3.0 incompatibility problem. I had no trouble connecting my phone to my old PC which had win 7 home, and USB 2.0 ports. I had originally thought the problem was going from win 7 home to win 7 prof. Now I think the problem is going from USB 2.0 to USB 3.0.....give it a try and see if it helps you out.


Try this

  1. Go to dial pad & type *#0808#

  2. It displays USB settings

  3. Select MTP+ADB option

  4. Press OK button

  5. Connect to USB cable to PC

It shows Connected as a media device.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .