It used to work fine but now when I open the Play Store app it says "Error retrieving information from server. [RH-01]" and I can't do anything. I tried clearing the cache of the Google Play Store and Google Play Services but it still has the problem. Gmail still works from the phone so I don't think it's a problem connecting to my google account.

I have an Xperia Arc with custom rom, which turns out to be the problem. See accepted answer.

  • This is maybe caused by a buggy gapps package and/or custom ROM. At least it seems not to happen on stock ROMs. If I am wrong, please comment here.
    – Flow
    Jan 10, 2013 at 23:29
  • 1
    @Flow It can happen to stock, but it is not too common
    – Dan Brown
    Dec 31, 2015 at 10:31

2 Answers 2


This could be caused by flashing an incompatible GApps package. If that's not the case (and you are sure you have the correct/compatible GApps installed), try the following:

  1. Open the "Google Play" app and press the home button to return
  2. Go to Settings → Applications → Manage Applications
  3. Select the "ALL" tab, Search for "Google Play Store" and press it to open.
  4. Press "Clear cache"
  5. Press "Force stop"
  6. Return to Settings → Applications → Manage Applications
  7. Press "Google Services Framework"
  8. Press "Clear Data"
  9. Press "Force Stop"
  10. Start "Google Play Store" and it should give an error
  11. Reboot. Once your device has restarted Google Play Store should work. Wait a minute or too if it doesn't.

This should help if a corrupt cache is the cause of your problems (a corrupt cache might lead to strange error messages, amongst others). If it doesn't help, you might try the same steps but include "Clear Data" for the playstore app.

  • What is a GApps package? I flashed nothing but the ROM itself.
    – Celeritas
    Dec 2, 2012 at 3:16
  • 1
    Custom ROMs many times do not include the Google Apps (GApps: Playstore, GTalk, Maps, etc.), but offer them in a separate package/zip. That's the so called "GApps" package (Google Apps). I take it then your ROM already included them already?
    – Izzy
    Dec 2, 2012 at 12:16
  • It didn't have Google Maps and I really needed it tonight so I decided to flash a different ROM (so this problem doesn't exist anymore). Thanks for everyone's help though!
    – Celeritas
    Dec 2, 2012 at 12:41
  • this worked for me in 2016, Asus ZenUI, Non Root Android 5.0 Nov 11, 2016 at 12:05
  • 2
    @Maveň no root access needed for any of the steps. See Gaurav's comment right before yours, his device wasn't rooted either.
    – Izzy
    Feb 14, 2017 at 8:11

Apparently some custom ROMs do not come with any Google services and to fix this you need to flash gapps using a program such as Clock Work Mod. This page has a link to download gapps.

  • Custom ROMs rarely ship with Google Apps already integrated. So I wonder how you were able to a) run the Play Store app and b) clearing cache from Play Store + Google Services (as your question states) if those haven't been installed :)
    – Izzy
    May 2, 2016 at 9:54
  • Good point, too bad it's been so long now I've forgotten.
    – Celeritas
    May 2, 2016 at 16:54
  • Thought so. Still added it for other confused people like us, so they don't think they've gone nuts and are the only ones seeing a discrepancy here :)
    – Izzy
    May 2, 2016 at 19:30
  • You said it. Read your own comment again (emphasis mine): You flash gapps. Separately. They don't ship with the ROM. If you just install the ROM, but don't explicitely flash GApps, there are no GApps. Clear? :)
    – Izzy
    Jul 15, 2016 at 21:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .