3

I am using a Galaxy Nexus and since the update to Android 4.2 the screen sometimes suddenly goes off and then especially stays off. The only thing that helps to get the screen back on is taking out the phones battery, which is quite annoying.

Is there a workaround for this?

1
  • 1
    For what it's worth, I get this on 4.1.1 on my Verizon Galaxy Nexus.
    – ale
    Dec 7, 2012 at 17:46

4 Answers 4

1

The same thing happens on my Nexus 7 running 4.2 and as answered in the other question the only way I found to get the screen back on was to perform a "soft reset".

Hold down the power button for around 30 seconds, the device should start a soft reset (i.e. you don't lose any data/settings etc.) and reboot. Not really fixing the root cause of the issue but it's easier than taking out the battery every time.

This is also assuming the holding down the power button to reset works on the Galaxy Nexus and that it's the same issue but it sounds very similar and has only happened after I upgraded to 4.2.

2
  • unfortunately this soft-reset way does not work on the galaxy nexus ): Dec 7, 2012 at 18:46
  • 1
    Ah okay, I'd read in a few places that it might. There's a suggestion in this thread: forum.xda-developers.com/showthread.php?t=1541052 that 'Holding power and both volume buttons' might work, or "Press and hold the Power and Volume Down buttons together for 10 seconds" For my Nexus 7 it takes closer to 30 seconds to turn off so maybe try holding it for longer.
    – Peanut
    Dec 7, 2012 at 19:08
0

It could be that something in your data is causing this to malfunction - to solve this you would have to do a factory reset.

Before you do that however, please try and do a soft reset (remove battery for 10 seconds, reinsert).

If that fails to work, do a full factory reset - you will want to ensure you have backed up your apps beforehand.

If that also fails to work, then it is most likely a hardware issue, and you will have to have the screen replaced.

3
  • 2
    I really don't want to wipe anything on the device, I don't have time to set up all stuff again \: If there's no easier workaround, I will wait for a fix. Also, I guess that wiping fixes the bug is just a guess? Dec 2, 2012 at 16:28
  • Yes - but it seems to fix most 4.2 issues, although I believe Google should have waited longer before they released it. This does sound to me like a processor issue however, which could mean Google have underclocked the processor too much in this release...
    – Liam W
    Dec 2, 2012 at 16:30
  • Wiping isn't really a good answer though especially if you think it's a hardware issue.. edit: sorry just reread what you meant, but still wiping wouldn't be a good solution if it's because of the OS.
    – Peanut
    Dec 7, 2012 at 17:40
0

the solution: enable animations http://code.google.com/p/android/issues/detail?id=40019

-1

Disable automatic brightness in your settings.

1
  • 3
    Okay, I'll bite. Assuming this works, why?
    – ale
    Dec 7, 2012 at 17:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .