I go to Google Search app but no Google Now "cards" are showing.

I do the ff:

  1. Long-press Menu soft-key to bring up Google Search
  2. Press Menu -> Settings
  3. Under settings, I only get 3 entries: Voice, Phone search and Privacy & accounts (no Google Now)

My friend, who uses an HTC Sensation with MIUI ROM, and Google Now works nicely.

Question is, how do I enable it on my Note 2?

*I am suspecting that this has to do with my Privacy settings or Location settings but I still haven't gotten it to work despite changing those settings...

  • I wouldn't think that it's to do with your location services, I know that if I have "Access to my location" turned off in "Location Access" in the phone's settings, then as soon as I open Google Now the first card says: "Location service is off: To continue using Google Now, you need to turn on Google's locations service" with a link to the relevant section in Settings.
    – GAThrawn
    Dec 3, 2012 at 9:39
  • Is it country-locked? Where are you located?
    – ale
    Jan 2, 2013 at 17:03
  • The answer has already been provided. It was with the Language setting.
    – Eric
    Jan 7, 2013 at 3:15

4 Answers 4


The language setting was my key problem - after changing the OS language from Croatian to English (U.S.), Google Now is miraculously ready to go!

Watch the video How to get Google Now talking to you... for an instructional guide on changing your system language.

  • This solved the issue. I had to change the language to English (United States) to get it working. Thanks.
    – Eric
    Jan 7, 2013 at 3:13

You must be running at least Android 4.1 to use Google Now - please ensure this is true.

If you are running at least Android 4.1, then ensure you have the latest Google Voice Search update from the Google Play Store - be aware that it is listed twice (at least on my old device).

  • The Galaxy Note 2 I got had 4.1 out-of-the-box. I have also updated Google Search and Google Voice Search doesn't have an Update option when I checked today.
    – Eric
    Dec 5, 2012 at 3:52
  • @Eric Strange. Have you tried clicking on the voice search widget?
    – Liam W
    Dec 5, 2012 at 6:56
  • Yes. Still no "Google Now" in the Settings menu
    – Eric
    Dec 7, 2012 at 5:27

Have you checked that you are running the latest version of Google Search? The easiest way to update is to visit the Google Play Store page for Google Search and check to see if it will allow you to install or update the app.

Ok, so I found how to turn on Google Now on my GN2. If you have the Google search widget, it is as simple as hitting the settings button (left light-up one) while inputting a query for the search widget. This brings up a menu, hit settings then you can turn on Google Now.

I accidentally opted out when in early setup, and now I am curious.

  • Yes. I uninstalled updates and re-installed updates but Google Now still isn't showing under "Settings" in Google Search
    – Eric
    Dec 5, 2012 at 3:53

Ok, I think this is how you do it.

Open Google Search from the app drawer. Tap on menu and then settings, then tap Google Now - you should be able to toggle it on from there.

  • Oops, just saw your other post about Google Now not showing in settings of Google Search. Seems pretty odd. I wonder if you need to do a factory reset? The other thing to do before that maybe is just to try clearing data in Google search? Dec 13, 2012 at 19:06
  • I have tried clearing Google Search data to no avail. :( I guess I will try to do a Factory reset soon because I too think that this is the last resort. Thanks for contributing.
    – Eric
    Dec 17, 2012 at 5:38

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .