I've got a Nexus 4 running Android 4.2.1 on AT&T (via Straight Talk). I've noticed that sometimes at work (low signal area) instead of getting low bars (zero to two at my desk) I'll get "no service", with an empty triangle instead of the shaded in triangle with an H over it.

Moving to a place with better signal (outside, at home) doesn't bring back the signal indicator, but rebooting the phone does. I don't think it always does this, either, but I may have just not noticed. Once I even got "emergency calls only" which I've only previously seen when I had my SIM card but hadn't activated it.

The weird part is rebooting the phone at work brings back the signal meter too; the problem seems to persist until a reboot. Turning airplane mode on/off didn't seem to work. What's causing this? It seems like once it loses signal it just kind of stops looking for a signal until it reboots. Is there some way to prevent this or force it to reacquire a signal once I know I'm in an area with signal?

  • I'm having similar situation however I have no problem with the signal strength. In my case I use WiFi in the office. In some ares WiFi signal is to weak and phone switches to HSPA. Usually once a day phone enters no service state and reboot is the only way to fix it.
    – jrumbinas
    Commented Jul 4, 2013 at 13:27

1 Answer 1


I've solved part of this issue; switching to Airplane mode and back (bring down the status bar, go to the quick settings panel, tap airplane mode twice) DOES restore signal if you're in an area with signal. So there's that at least, but it's still losing signal until a forced update. You might have to wait a second between the first and second tap of the Airline mode button to make sure it activates (the airplane icon will appear in the status bar).

Also note that occasionally it seems the phone will actually still get a 3G/4G signal and a stable internet connection...while still displaying the "no signal" icon. The only way to know this is happening is to try and use online features and find them working. You might just want to do the Airplane mode trick anyway since it's quite confusing to have the no bars icon but have the internet and calls working (and of course in this state you won't notice if the signal suddenly drops again).

  • 1
    Does not work in my case, unfortunately
    – alexeit
    Commented Jan 14, 2013 at 20:08
  • 1
    Doesn't work in my case too
    – jrumbinas
    Commented Jul 4, 2013 at 13:19
  • This solution works for me, but I can't just tap Airplane mode twice in quick succession. I have to wait until the airplane icon appears in the status bar before I tap Airplane mode a second time. I don't know why that is.
    – Mingo
    Commented Aug 9, 2013 at 3:55
  • @Mingo yeah sometimes it does that and sometimes double tapping immediately works. Very frustrating, and still happening on Android 4.3. Added some info to the answer
    – Ben Brocka
    Commented Aug 9, 2013 at 13:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .