So my Galaxy Nexus has been fine until now. It has been running Android 4.2 and it was going perfect, then like a day ago I go to plug it in and it just won't connect via USB. It charges on USB but that's it. The drivers are installed and the problem is not my computer; I tried it on another computer as well, I haven't changed anything at all. The last option I think for me is to do a factory reset, which I reaaally don't want to do.

It won't even come up with USB connected on the phone.

Any ideas?


I sent mine back for repairs and the mobo was screwed on it. No idea what caused it.

  • I think I have narrowed this down to a thing called "fastcharge" being enabled. – FabianCook Dec 9 '12 at 0:29
  • When you've connected it via USB, check your notification area. On my devices I get a notification there asking me whether to connect it to the PC or to charge only. Not sure, though, if the same will still be valid with 4.2 -- but it's worth a look. Maybe you've simply set it to "charge only". – Izzy Dec 9 '12 at 0:52
  • 1
    No notification, and I cant find any charge only option. – FabianCook Dec 9 '12 at 6:34
  • 1
    I've had similar problems with the Nexus S and also with the Glaaxy Nexus, I was never able to isolate a cause. Uninstalling/reinstalling the drivers, downloading drivers from Samsung's website and using a different cable have all worked at various times. – Peanut Dec 30 '12 at 5:31
  • I have put it down to a fault usb socket on the phone. – FabianCook Dec 30 '12 at 7:07

12 Answers 12


Replace the USB port. You can find them (port and ribbon) on eBay for $13, including shipping.

  1. There are 6 screws to open the phone up.
  2. Separate the outside case; there is 1 screw at the bottom once you open it. Take out the large black piece (I think its the mic and vibrating mechanism).
  3. Undo the bottom portion of the antenna.
  4. Undo some of the connectors on the the main board to be able to lift the bottom up some and gain access to the USB ribbon.
  5. Remove and replace with new ribbon. Be careful when lifting the main board and removing the USB ribbon to make sure nothing is connected so you don't rip or break anything.
  6. Plug all connectors and antenna back in.
  7. Put the battery in to make sure it turns on and you have reception.
  8. If you're good, turn it back off and screw everything back together.

Make sure you get a little kit off eBay with the tiny screw drivers and the plastics tool to pull apart the case housing.

  • 2
    I think I will send it back to the suppliers under warranty. Its pretty new so this kinda thing shouldn't happen. – FabianCook Jan 6 '13 at 22:01

Funny thing is: Blowing into the phones USB solved the problem for me. Maybe you try that =D

  • 4
    Ah, the Atari Cartridge repair process. – ale Aug 26 '13 at 14:28

as previously stated:

  1. Blow hard into the phone's port to clear out the dust & other garbage
  2. If you're connecting it to the front of the computer make sure nothing else is plugged in
  3. Connect it to the back of the computer., much better & STRONGER connection than the front
  4. If you're connecting to laptop, Again., first blow into the phone's port, do not connect anything else & try all different ports.

Go to Settings > Storage > overflow menu (three vertical dots) > USB computer connection. You can choose MTP. From now on, there will be a notification when you plug the USB device.


Definitely the cable for me. I notice that all of my USB cables have a much smaller diameter than the one that cam with my Nexus. When I use the the thinner ones I get nothing, no charge, no data connection. When I use the one that came with the phone everything works. Seems you just can't try different cables. Again a noticeable difference in the diameter of the cable.

  • I have used many different USB cables that are not for the device that I own. The only device that I have seen that used a "special" USB cable was my Nook Color, but I could still charge it with other cables, I just couldn't use that cable on other devices. The port that is used on devices is a standard, micro-USB. – Ryan Conrad Feb 3 '13 at 14:46

I have this problem too sometimes, with different cables and different computer. my samsung galaxy nexus charging full, charging usb, but not see the contents. I put something under the cable that pushes it a bit up just at the connector on phone and then suddenly it connects perfectly. hope it helps.


it's definitely a matter of USB Cable! I came here to solve my connecting problem, too. I then tried the cable that came with my Galaxy Nexus and now it works perfectly. Not every USB cable works, for sure now.


Update 12/5/2013: Found out that fast charge was enabled, disabling USB debugging and storage access.

I know this might be late, so this is mainly for future reference.

What I have: I am running CyanogenMod 10.1 M2 (Android 4.2.2) on a Galaxy Nexus, Latest Firmware / Band Updates, Using latest Samsung USB drivers.

I had the issues: Will not connect to Windows 8 computer as mass storage device, or over ADB (However Android unit was charging).

Solution: Full reboot.

This might be a issue with Android 4.2.2; I will submit a bug report.


Go to Developer options and uncheck the USB debugging option and it should work.

  • Sorry. Read the comments. I am not some "noob" its nothing to do with adb. The actual phone its self doesn't connect to anything for data transfer – FabianCook Dec 30 '12 at 7:09

Try the Tethering and portable hotspot setting (located in Settings → Wireless & network), then check USB tethering. This worked fine for me.

  • Won't solve the problem. – FabianCook Feb 13 '13 at 2:10

Go to Settings > Storage > Options > USB settings and select a desired USB connection mode.


Check this out. Don't do a factory reset yet because the problem probably has something to do with the cable not the phone. This seems to be a relatively known problem. look at this Google search.

  • I have tried multiple cables. Still not working. When I get my dock it might work. But have no idea why its not working now. Really need it for development – FabianCook Dec 9 '12 at 7:04
  • 2
    And what is "this"? Answers on Stack Exchange sites are expected to be self-contained. At best, when that link no longer functions this answer has no value whatsoever. – ale Jan 9 '13 at 14:06

Not the answer you're looking for? Browse other questions tagged or ask your own question.