15

I'm using Google Calendar on my desktop computer. It seems to auto-generate birthday entries for my contacts in Google Mail. Unfortunately these entries show up twice in "My calendar" in the generic Calendar app (version 1.1) of Android 4.0.4. How can I avoid this?

I don't see any duplicate entries in other calendars, and the calendar list only shows "My calendar" once.

Written on my Samsung SII :-)

4
  • 1
    You are using Google Calendar app on your phone from the Play Store, correct? Or are you using a ROM based Calendar app (Sense, etc.)?
    – Bryan Denny
    Dec 10, 2012 at 14:17
  • @BryanDenny I'm using the one which came with the phone, not a downloaded one. It's simply called "Calendar" (version 1.1 according to the "App info" page).
    – l0b0
    Dec 10, 2012 at 16:22
  • What phone do you have?
    – Bryan Denny
    Dec 10, 2012 at 19:22
  • @BryanDenny Samsung S II
    – l0b0
    Feb 18, 2013 at 10:41

5 Answers 5

9
+50

Here are some options you can try:

  • Remove your Google account and adding it back. Source
  • Clear app data via Settings > Application manager > Calendar Storage > Clear data. Source.
    UPDATE 2013-05-15: This worked for l0b0
2
2

It's possible that the calendar app is showing the birthday in the "My Calendar" and also from the "Contacts' birthdays and events" from google calendar (which you can set up from the website, birthay is in the more section of "Interesting Calendars"). If is the case they should show up with 2 different colors. You can turn on of these calendars off in the 'Calendars to display' options (from the menu).

The other option is that merging/linking contacts (i.e. if a contact has an exchange account and birthday info) ends up in duplicate birthdays entries added to the My Calendar, and show with the same color. So far I delete those by hand.

6
  • They actually show up with the same color and title. I checked in the app, and they both belong to the "[email protected]" calendar.
    – l0b0
    Feb 18, 2013 at 10:41
  • @l0b0 If you go to calendar.google.com, are there duplicate entries as well?
    – frozenkoi
    Feb 19, 2013 at 0:20
  • As mentioned in the OP, no.
    – l0b0
    Feb 19, 2013 at 6:36
  • Just to be clear, this solution is not applicable.
    – l0b0
    Aug 8, 2013 at 8:23
  • @l0b0 I think this answer will still get half the bounty though, since it has at least 2 upvotes.
    – geffchang
    Aug 10, 2013 at 16:48
1

Sorry to bump this up guys, but I think I got the solution to your problem, l0b0. I chanced upon this post while trying to solve the same problem faced by l0b0. I'm currently using Samsung SIII, and I synced my phone contacts to my gmail account. The birthdays of my contacts appear 3 times, with the same colour (under "My Calendar" in Google Calendar app).

I unclicked "My Calendar" in my Google Calendar App, and the contacts disappear. I think the duplicates are because of the contacts I have on my phone. To keep my friends' birthdays appearing on my calendar, I opt to click "Birthdays" instead. Hope this helps!

0

is it possible your Calendar app is synced with more than one account? If it is, the birthdays which were copied into your calendar from account A may have now been backed up onto account B. You can check this by going to Accounts and un-syncing all but one of your calendars.

1
  • I have only ever had one account, so no. Also, I only see duplicates in Android, not on the Google Calendar web site.
    – l0b0
    Dec 26, 2012 at 21:17
0

If your calendar is showing twice same events, and even in the same color, it could be because your phone has a default option to show contacts birthdays. So go to settings in your calendar app (in your phone), and look for your "sync calendars", and uncheck the one called Contacts Birthdays. So in the website you'll see the one you're used to, and in your phone you'll see the one by default your phone comes with.

If nothing disappears, or both duplicated events disappear, means those events are stored in another calendar, or you have duplicated entries in your calendar. In that case, from the website go to your contacts and in the "more" option select "find and merge duplicates".

Hope it helps.

3
  • Both of the events disappeared when deselecting the "Contacts' birthdays" checkbox. I just verified that a random duplicate entry did not correspond to a duplicate contact (I regularly import contacts, and always use "find and merge duplicates" afterwards).
    – l0b0
    Aug 9, 2013 at 19:49
  • So if unchecking ONE calendar from the ones you have makes both events dissappear, means all birthdays including it's duplicates are in same calendar. I would recommend to check the calendar via web, unsuscribe from that calendar, sync the phone and make sure all birthdays disappear, and then, suscribe again to the birthdays calendar, make sure via web appears only once. If after doing that, in web appears once and in phone appears twice, issue would be the phone, so test your calendar in other android phone. Aug 13, 2013 at 23:48
  • An after all of that, if in that other phone you test everything seems to be fine, I guess best choice is to uninstall calendar app (if you're rooted) or factory reset your SII. Aug 13, 2013 at 23:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .