This morning I woke up to my Samsung Galaxy S3 which just “hung” during the start-up screen with the white text “Samsung Galaxy S3 GT-19300” on a black background. It never comes to the “Enter Pincode” screen.

It worked without a problem when I went to sleep last night. As far as I know it should not update the software on its own, similarly the apps shouldn't update themselves without my confirmation.

I have tried to restart it and to take the battery out and put it in again but the result is the same.

Any suggestion or advice on how to fix this would be so much appreciated.

  • Have you seen this thread? Commented Dec 12, 2012 at 9:09
  • I too am experiencing the same problem. All attempts to reset/hard reset, enter download mode/recovery mode have been unsuccessful. Any attempt just results in the phone turning off/on and remaining stuck on the back screen with white samsung text. The problem occured while I was actually using the phone browser, phone just suddenly reset and now I am having this issue. All help will be appreciated.
    – user25164
    Commented Dec 18, 2012 at 2:46
  • Are you using a custom ROM? What you're describing is typical when a modified kernel you are using is not suited for the ROM you've flashed.
    – Harsha K
    Commented Dec 18, 2012 at 3:38
  • Same problem. Hard reset doesn't work (can't get into that screen via the volume up/home/power button route). Did you by any chance just install AppBrain Ad detector? I did, so it's just a thought. (sorry I can't add this as a comment, so I've added it as an answer which it probably isn't...)
    – user25233
    Commented Dec 19, 2012 at 10:19
  • Hi everyone and thanks for your comments. My phone was not rooted or using a custom ROM, everything was the same as when it left the factory. I eventually went down to the store and they take a look at it. Sadly it ended with the phone being repair because there had been some malfunction in the memory-reading hardware it only was the ROM which was booted, no the operating system itself (or something very like that, can't remember the exact words from the tech guy). Thanks for all your comments.
    – Mestika
    Commented Dec 20, 2012 at 7:21

2 Answers 2


Your system might have become corrupted or hampered by some misuse/mishap. The method below will install Latest factory Firmware for your Samsung device, i.e., Unbrick the phone.

Steps to Install latest firmware

Note: Write your phone's model number like "GT-I9812" and IMEI number on paper beforehand.

  1. Put your device in Download Mode.

    Don't connect your device to USB port

  2. Now, on PC, download and install Samsung KIES.

  3. Now, after installation, reboot PC. All required drivers will be installed for the PC and android device.

    Connect your device to the PC

  4. Open Samsung KIES, Go to Tools > Firmware Upgrade and Installation.

  5. Dialog will popup asking for Model Number. Put Phone's Model Number which you have written on the paper and Press Next.

  6. Now, it will ask for the IMEI number of the mobile phone. Just put that in and Press Next.

  7. There will be some dialog boxes about the system reset and warnings. Just Click Ok/Next.

  8. Now,Samsung KIES will download system software for the device and Install it on the device itself.

    This will take lot of time, so be patient.(Time depends on the Your Network Speed.)

Voila! Your Phone is New Again. (atleast on the inside. :-P)


Sounds like a corrupted operating system preventing a full system boot. I would flash a stock system image. I have provided links below to a few helpful resources that will hopefully get you back up and running!

Take a look at this website: http://forum.xda-developers.com/wiki/Samsung_Galaxy_S_III/GT-I9300

Navigate to the enter download mode section.

Then follow this instruction to reflash your phone back to stock: http://forum.xda-developers.com/galaxy-s3/general/tut-unroot-galaxy-siii-stock-updates-t1710613

This should help!

  • 2
    You should put the instructions in your answer. In case the link dies, your answer will become useless.
    – Thomas Vos
    Commented Jun 29, 2015 at 6:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .