I accidentally let the battery on my Nexus 7 run completely empty, and now it won't start up anymore even after charging overnight. How can I make it work again?

This is what happened in detail: My battery ran low, and I had no time to recharge it. I forgot about it, and found my tablet powered off. I attached it to a charger (the official wall-plug adaptor), waited a few minutes, and then turned it on. I expected it to be able to run from the cable like my phone, but it reported 0% battery and shut itself down immediately. I retried it after a slightly longer time. This time I didn't get to the home screen, but was shown a black and white animated battery icon. I pressed the power button, and the animation froze, and only disappeard after a long time (I put it away and discovered it was gone after a few hours). Since then I've been loading it for > 12 hours, but I haven't been able to get any response. The charger gets warm, but the tablet doesn't.

I've heard that once the battery is competely discharged, it only charges in "trickle mode" (that is normally used to top off a 98% loaded battery safely), and can take a very long time to become operative again. This would explain why the adapter gets warm but not the tablet. If this is true, is there any way to speed up charging?

  • 1
    Are you charging via an AC adapter or USB cable? If you're using USB, use an AC/power adapter. Does pressing the power button for 30 seconds do anything?
    – Bryan Denny
    Commented Dec 12, 2012 at 13:59
  • Both :-) the stock AC adapter uses a USB cable to connect with the tablet. I'll try the 30 seconds trick next.
    – jdm
    Commented Dec 12, 2012 at 14:03
  • Opps, I guess I should have said: USB to a computer or USB to AC adapter. Try the 30 second trick and let me know if it works
    – Bryan Denny
    Commented Dec 12, 2012 at 14:06
  • @BryanDenny Holding it for > 30 seconds worked! Thanks!
    – jdm
    Commented Dec 12, 2012 at 14:07
  • Related: android.stackexchange.com/questions/34829/…
    – Peanut
    Commented Dec 12, 2012 at 16:16

1 Answer 1

  1. Try pressing the power button for > 30 seconds.

  2. If it does not work, try to alternate power sources (PC/laptop USB port, and AC adapter) while repeating step #1.

  3. Still no go? You may have to remove back cover and reconnect battery.

  4. Warranty case.


  • Wow, it worked, thanks! 30 seconds is a rediculously long time, I would have never thought of that by myself. Every other device I have that has long-press functions needs 5 seconds, 10 seconds max.
    – jdm
    Commented Dec 12, 2012 at 14:06
  • Fantastic! Glad it worked for you!
    – Bryan Denny
    Commented Dec 12, 2012 at 14:07
  • And be sure to mark this as the answer
    – Bryan Denny
    Commented Dec 12, 2012 at 14:10
  • I have done steps 1-3 with no luck, and it's out of warranty. I've been charging it with the original power adapter. When I first plugged it in to charge, it booted and immediately shut down due to low battery at least twice. Since then I've had no activity at all. Is there any hope for me?
    – fredley
    Commented Oct 20, 2013 at 21:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .