Brand new LG GT540, everything works except for the Market. Clicking on Install on any App resultings in it sitting on 'Starting download..." for several seconds then as soon as it changes to "Downloading..." it fails with 'Download was unsuccessful, please try again'.

This is not a duplicate of 'Sometimes Market update get stuck downloading, how can I cancel?' which is 'sometimes' and about cancelling. The answers do not work/are not relevant. It is also not a duplicate of 'Android market - Application downloading problem' which sits at 'Starting Download...' for several hours.

There are several solutions floating around on the web, but like myself, it seems to not solve it for a vast amount of people. I believe there is more than 1 bug with downloading from the market but they are getting treated like one.

Firstly, there is the GTalk related issue. This is not relevant in this case. GTalk signs in correctly and works. Signing out of GTalk and back in does nothing to fix the issue. Neither does clearing the data out of the GTalk App and/or Google Apps and rebooting the phone. It is not a GoogleMail/GMail issue either as this is not in the UK and has always been a GMail account.

Secondly, it is not solved by clearing the cache/data out of Checkin Service/Downloader/Market, etc. I had done this clearing/force stop on ALL the applications suggested across the web and rebooting the phone. This has been done several times with no effect.

Thirdly a factory reset doesn't work either. Makes sense considering this behaviour has been straight out of the box.

EDIT: I have also tried unmounting the SD card, removing it, rebooting the phone and trying to download with no difference.

EDIT 2: Clearing everything and signing into the Market with a brand new account made no difference.

Any other ideas on what the cause of the issue is and how to fix it?

  • Have you tried from a WiFi connection? Could it be a network limitation
    – gary
    Commented Dec 12, 2010 at 0:51
  • I have a HTC Desire HD that is working perfectly from the same location, not on WiFi. Have literally tried it right next to the tower when out in town with no difference. Commented Dec 12, 2010 at 2:43

3 Answers 3


The cause of these problems is a bug in Google Framework Services, at least in 2.1 and 2.2.

I have been able to fix it temporarily by clearing the cache for all Google apps -- GFS, Talk, Voice, GMail, Market, etc. -- but I do not believe there is a permanent fix. Perhaps in 2.3, I don't have it on my phone yet.

  • This sounds like one of the other issues. I have cleared EVERYTHING then rebooted the phone with no difference. I think If I tell my wife she has to enter her gmail user/pass one more time... lol. This is on Android 1.6 btw. Commented Dec 12, 2010 at 4:55
  • Since it's the same problem with the same apps I would still guess that it's the same bug, even if it's aggravated in your case. Do you have multiple Google accounts on the phone? I have begun wondering if that might trigger it. Commented Dec 12, 2010 at 5:25
  • 2
    Well, not really. In a lot of the other cases GTalk has issues as well. GTalk in this case has worked flawlessly. That's also a big no to multiple Google accounts as well. It's my wife's phone and only gets set up with her gmail account. Commented Dec 12, 2010 at 5:29
  • Ah, I misinterpreted "Signing out of GTalk and back in does nothing" to mean you couldn't sign out. Commented Dec 12, 2010 at 5:33

Is this a Google account issue or an issue with the phone+software combination? Is it possible for you to use the same Google account in another phone (or different Google account on the LG phone, since you seem to have reset it a few times)?

  • Brand new account made no difference, unfortunately. Commented Dec 16, 2010 at 4:13

I uninstalled all updates to Market app (Android 1.6) and since then I'm able to download new apps/updates successfully

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .