2

I have a 32 GB Nexus 7 (idVendor = 18d1, idProduct = 4e41, if that helps...), and my laptop runs Ubuntu 12.10, and have tried connecting using K.K. Patel's answer here, to almost no avail. What happens is that the "GalaxyNexus" folder is created, and then when I try to navigate to it, it has two sub-folders "Playlists", and "Internal Storage" (I cannot add a file or folder here, which is the first point of concern).

When I navigate to "Playlists", the folder opens to a nice blank screen and I guess that's to be expected (I haven't been able to put music onto it yet).

When I try to open the "Internal Storage" folder, it opens a new window that is the same as the first ("Playlists", "Internal Storage").

So I tried going in through the terminal to a similar fate. Anyone experienced this problem and/or know what to do to fix it? I really just want to be able to transfer files to the device.

2

Jelly Bean devices do not use USB Mass Storage to mount themselves on PCs. They use the more secure MTP method, and Ubuntu does not natively support MTP.

The method you have linked to is the only official way to do what you want.

I own a Nexus 7, but I am using a custom ROM, and as such, USB Mass Storage is hacked into my build. However, I believe on the stock ROM, if you check in Storage and you press Menu, you should have an option to set the USB connection type, and there is a Picture Transfer mode. It won't let you see all of the files on your Nexus, but it will allow you to copy and it shouldn't need any extra help inside Ubuntu.

For an extremely detailed explanation on MTP and why it exists, and why on the stock ROM you will never be able to use it as a flash drive, I highly recommend you check this StackExchange question:

How can I use my Galaxy Nexus as an external USB storage drive?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.