My Samsung Galaxy Ace GT-S5830 has just “hung” during the start-up screen with the white text “Samsung www.samsung.com" on a black background.

I have tried to restart it and to take the battery out / put it in again but the result is the same. It neither goes into Download Mode (vol down+menu+power button) nor RAM Dump Mode (vol up+power button).

Does anyone have any suggestions or advice on how to fix this?

3 Answers 3


Plug it into your computer and see if by some offshoot chance you have adb available. If so, run a adb -d reboot-bootloader to reboot into download mode.

If that's unavailable, you are SOL and will have to have Samsung repair it. Honestly, if it's hard bricked, you're better off buying a new phone...


Sorry to say this, but if it will not go into Download Mode then your only hope would be to take into a service centre to get it repaired.

They would most likely charge you if you're rooted or have a custom ROM installed. Apologies for the bad news!

  • Done that buddy..they asked me to change the mother board of da phone.Thanx
    – MAX
    Dec 18, 2012 at 21:07
  • @Max. Then what are you asking here for? Get them to change it :)
    – Liam W
    Dec 18, 2012 at 21:14
  • Thy say it will tak a month
    – MAX
    Dec 18, 2012 at 21:18
  • I thought I must have an option to boot up my phone through Eclipse DDMS but I cant find any option there either!
    – MAX
    Dec 18, 2012 at 21:30

I found a post on XDA that suggests you have to hold Home + Power till the device starts and shows the Samsung symbol, then let go. Holding it till "Samsung" appears is very important! This worked for my Galaxy Ace GT5830.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .