It used to work just fine then I upated to 4.2 and enabled developer options (one or the other must have broken it) and since then it has stopped working, it shows up as a camera device but if I change it to MTP it doesn't work.

I tried turning developer options off, I tried re-installing drivers and a few other things.

How do I make it work again like it was in 4.1 when it worked even when usb debugging was enabled? Now it won't work at all.


6 Answers 6


What worked for me (on Windows) was:

  1. Plug the Nexus 7 into your computer with the USB cable.
  2. Open Device Manager: Start -> Run (or Win+R), type in: devmgmt.msc and hit enter. This opens up the device manager.
  3. Find "Android Composite ADB Device" near the top and expand the node. Double click on the device. (Note: Sorry, I don't see it anymore so it might be named slightly differently.)
  4. In the properties window that pops up, uninstall the driver. You should choose to delete the current driver as well.
  5. Unplug the tablet and plug it back in.

At this point mine got recognized as a Nexus 7 instead of an Android ADB device and allowed me to transfer files again.

I'm not sure how this will affect debugging (especially if you delete the old driver) but it worked for me after days of searching.

  • 11
    It worked for me too, but just to confirm, "delete the current driver" must be checked!
    – mdelolmo
    Commented Apr 24, 2013 at 13:36
  • Above steps worked for me, then I reinstalled the Google USB drivers after updating them with the SDK manager and it showed up both in explorer and via ADB. Commented May 3, 2013 at 4:49
  • +1 Deleting the driver does matter. Definitely do it. Commented May 4, 2013 at 19:54
  • Above steps worked for me, then I reinstalled the Google USB drivers after updating them with the SDK manager and it showed up both in explorer and via ADB. In addition to that I had to de-authorize the computer from android device settings (nexus4) and then disable-enable debugging, and then reconnect the device to windows via usb.
    – hB0
    Commented Nov 3, 2013 at 21:58
  • Dose not work for me as my device is completely invisible to the device manager. There is no entry anywhere in there for me to click on.
    – Elliot
    Commented Apr 4, 2014 at 22:38


Tried above steps. Trying to connect a Nexus 7 to Win7-64. The device in the Computer Management/Device Manager/Portable Devices, used to say Nexus 7, now it says MTP USB Device and has the ! with This device cannot start. (Code 10). http://pcsupport.about.com/od/findbyerrormessage/a/code-10-error.htm Essentially, this means uninstalling all devices and reinstalling them. I did that with my three other devices and the Nexus7. There was a USB hub that had those three plugged in, so I just unplugged the whole hub. Replugged Nexus7 to USB, it found it (when I went to Disk Management and did a rescan). Once Nexus7 was recognized, I plugged the hub back in and all was well again.

  • 7
    In StackExchange sites, ".. above steps .." does not mean anything because the answers get sorted by updates. If you think an answer has helped you, upvote it instead. :)
    – geffchang
    Commented Feb 26, 2013 at 5:31

This bug happens in some cases when upgrading. I fixed mine by changing quickly between MTP and Camera with the USB unplugged, then I put it back to MTP again and it worked fine when I plugged the USB back in

To change these settings go to Settings> Storage Then click the little menu button in the top right corner and click USB computer conntection.


I kept on getting "This device cannot start. (Code 10)." and after hours of repeatedly reinstalling drivers all it took to fix the problem was rebooting the actual phone.

In summary: don't assume Windows is at fault, it could be the phone. Try rebooting it after installing new drivers.


I had the same happening even to me. I ended up getting it to work by going to the device manager and uninstalling the device (it was showing up as Samsung phone). Then I unplugged it, plugged it back in and it was installed again automatically, working fine and showing up in MTP mode as Nexus 10.


Try enabling USB debugging in Developer options. It worked for me.

  • 2
    He's tried this, that's what the "I updated to 4.2 and enabled developer options" bit means I believe.
    – Peanut
    Commented Mar 30, 2013 at 19:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .