9

I'm trying to partition my external SD card (32GB SDHC), so I can link application to the second partition with link2sd. Now the problem is that, no matter what filesystem I use, link2sd can't create the mount script/fails to mount. I tried FAT32, FAT16, ext2, ext3 and ext4. Same result everytime, I tried formatting it with MiniTool Partition Wizard and ClockworkMod Recovery. I made the first Partition a FAT32 primary and the second partition an put in filesystem here primary partition. I also tried diffrent sizes between 256MB and 4GB.

I'm on Cyanogenmod 10 running on an Samsung Galaxy Ace (I-5380).

Edit: It seems like the question is quite popular. If you have the same issue, try the things that I said I tried above. In most cases this resolves the issue, my accepted answer is for a silly not so common cause for this issue.

2 Answers 2

3

Ok the problem was simple and stupid. SuperSU had denied link2sd its root access permanently, I must have clicked on denied once... Enabled root access for link2sd and everything was working fine.

-2

Go into ClockworkMod recovery → Advanced → Mount and storage and mount SD ext. Done.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .