So I just downloaded the nightly version of Firefox (ARMv6) apk and when I install, I get the following error message:-

Application not installed

This, isn't a very friendly message.. what could be the cause? How do I find out?

Logcat for this particular problem says:-

W/PackageParser(  137): Exception reading libxul.so in /data/app/vmdl70897.tmp
W/PackageParser(  137): java.io.IOException
W/PackageParser(  137):         at java.util.zip.InflaterInputStream.read(InflaterInputStream.java:207)
W/PackageParser(  137):         at java.util.zip.ZipFile$ZipInflaterInputStream.read(ZipFile.java:432)
W/PackageParser(  137):         at java.io.FilterInputStream.read(FilterInputStream.java:154)
W/PackageParser(  137):         at java.util.jar.JarFile$JarFileInputStream.read(JarFile.java:109)
W/PackageParser(  137):         at android.content.pm.PackageParser.loadCertificates(PackageParser.java:338)
W/PackageParser(  137):         at android.content.pm.PackageParser.collectCertificates(PackageParser.java:508)
W/PackageParser(  137):         at com.android.server.PackageManagerService.installPackageLI(PackageManagerService.java:5906)
W/PackageParser(  137):         at com.android.server.PackageManagerService.access$2100(PackageManagerService.java:134)
W/PackageParser(  137):         at com.android.server.PackageManagerService$5.run(PackageManagerService.java:4764)
W/PackageParser(  137):         at android.os.Handler.handleCallback(Handler.java:587)
W/PackageParser(  137):         at android.os.Handler.dispatchMessage(Handler.java:92)
W/PackageParser(  137):         at android.os.Looper.loop(Looper.java:123)
W/PackageParser(  137):         at android.os.HandlerThread.run(HandlerThread.java:60)
W/PackageParser(  137): Caused by: java.util.zip.DataFormatException: data error    
W/PackageParser(  137):         at java.util.zip.Inflater.inflateImpl(Native Method)
W/PackageParser(  137):         at java.util.zip.Inflater.inflate(Inflater.java:255)
W/PackageParser(  137):         at java.util.zip.InflaterInputStream.read(InflaterInputStream.java:188)
W/PackageParser(  137):         ... 12 more    
E/PackageParser(  137): Package org.mozilla.fennec has no certificates at entry libxul.so; ignoring!

Although I've encountered this on the Firefox APK, I'd prefer a more general answer on how to fix or know the cause of such "Application not installed" problem.

  • 1
    Have you uninstalled existing Firefox app, in case you had it? Dec 20, 2012 at 12:51
  • @SurajBajaj I never had firefox app installed. Never tried it.. (because firefox only recently released ARMv6 builds)
    – Irfan
    Dec 20, 2012 at 12:52
  • I am not sure how much it can help but still have you seen this question? Dec 20, 2012 at 12:57
  • Do you have enough free space? Did you check logcat? What device do you have?
    – Lie Ryan
    Dec 20, 2012 at 13:24
  • 1
    @Power-Inside Have you tried re-downloading the APK? May the APK is corrupt. Again a wild guess... Dec 20, 2012 at 17:26

2 Answers 2


The exceptions coming from zip (in the log extract) indicate that the package is corrupt. This error could have been introduced by the download, or when the package file was generated. You could check for download errors by verifying the APK file's SHA-1 or MD5 checksum against a checksum provided by the download site. Obviously each site will have a different way of telling you the checksum. Also, the method of verifying it is different depending on what OS your PC runs: on Linux it's as simple as running md5sum file or sha1sum file.

Note that this won't always be the case from the "Application not installed" error message. As others have indicated, that message usually results from trying to install a package that already exists on the system, unless the new package has a newer version number and is signed by the same key.

  • Yup! +1 from me, as this question was asked last year, presumably its happy days now for the OP in question :D
    – t0mm13b
    Aug 10, 2013 at 15:48
  • @t0mm13b Still a useful answer though, in case somebody encounters it. +1 from me too. :)
    – geffchang
    Aug 11, 2013 at 4:17
  • Well it did seem like a corrupted download. There was no checksum for me to compare with and I even tried restarting the download and completing it multiple times over and over.. seems like the server had hosted a bad APK. :)
    – Irfan
    Aug 12, 2013 at 17:08

Try to delete app's files in /data/data/package-name and /data/dalvik-cache/package-name (You need root access to do that). That fixed an issue with app that has been broken on my system and has error code -2 in logcat.

  • This doesn't seem like it would fix the issue since the error happened on the first install so those files were not present. Apr 15, 2015 at 16:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .