I haven't played around with custom ROMs since my G1 back in 2008, so when I put Cyanogen 10 on Galaxy S3 last night I wasn't surprised that things have changed a bit.

I rooted the phone first, then put on CM touch, then C10 and the appropriate gapps. My problem is that I can't see the ext sd that worked fine under the stock ROM.

These are the specifics:

  • recovery-cwm-touch-
  • cm-10.1-20121220-NIGHTLY-i9300
  • gapps-jb-20121212-signed

I'm trying to mount via the CWM menu but get this response:

Error mounting /external_sd!

I've also tried to use ICS SD Binder, but with no success.

Any help would be grand.

  • Please use a separate question for your separate issue (don't mix things), and then remove it from this question. One question per post is the premise here.
    – Izzy
    Dec 21, 2012 at 9:45
  • How are you mounting the EXT partition?
    – Liam W
    Dec 21, 2012 at 9:51

2 Answers 2


First to the recovery:

Samsung phones that use Odin have their recovery image as part of the kernel. You should flash the CyanogenMod zip file, and that should flash the CWM recovery. Alternatively, you could flash the Siyah kernel, which comes with a modified CWM touch recovery image.

Now to the EXT partition:

Make sure that the EXT partition is primary, and also ensure that your ROM has EXT support - you should ask on your ROM's forum post/website to check if it does. If it does, then it could be an issue with the mount script, if it doesn't well we know what the issue is now ;)

  • Thanks Liam. It seems that the 3rd flashing the CWM recovery has stuck; not sure why it took three flashes, as I didn't do anything different each time. As far as the the ext is concerned, I ask on the cyanogen blog. I'm trying to mount via CWM touch and it returns an error. Dec 21, 2012 at 12:46

finally found the solution. You have to fix the card first (which also means you can get back any data on the card).

On a Windows box I ran chkdsk.

Start -> cmd -> chkdsk e: /f

Then set the partition up as fat32, a 32GB partition. I did this on an Ubuntu box, for no other reason than that is my normal OS.

After popping the card back in the phone it was picked up and is being reported as 59.43GB

I tried a few things before I found the solution: http://exceptionallyexceptionalexceptions.blogspot.co.uk/2012/12/s3-mod.html

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .