I have an Evolio Evotab 2 (RK2918) running gingerbread


(sorry couldn't find english site with specs)

When typing fast it repeats the last letter instead of the one I just pressed. (for instance If I type Q and quickly go to K I get QQ )

I tried flashing other roms from similar chinese tablets but couldn't find one where everything worked.

Also it happens more often in landscape than when typing in portrait mode.

Can anybody tell me if this sounds like a software or hardware issue?

This is what I tried so far: -other keyboards than stock -tried typing in different places (browsers,apps) -other rom's -wipe+flash+root and uninstall allmost everything with TB = still happens.

Thank you.

  • 1
    Try calibrating the touchscreen, sounds like the calibration is off!!! – t0mm13b Dec 24 '12 at 16:51
  • Tried it, downloaded tscalibration.apk, did the calibration thing and restarted... no luck – user25485 Dec 27 '12 at 21:43

Hmmm.. a quick google-fu yielded this linky

To quote:

GPS: What should I do if touch screen ( display) is not responding? In case that the product is E100, E205, E300 or E400 press the RESET key.

If is S1200, A1700 or Xroad, follow the steps:

  1. Turn on the device and press key Menu M (up left), in case the GPS is turning on rolling an application it will return to the home menu.
  2. In home menu press key Menu then press 4 times key +( plus, up right) and once key – (minus, down right).
  3. If the steps were correct executed, on screen will appear a cursor +. Press, with careful, in the center of the cursor using the GPS pencil, marking the screen coordonats, center and four corners.
  4. After marking the coordonates, touch the screen anywhere for saving the coordonates.
  5. Next step “Touch Test” will confirm that the settings are right and will have effect on the device, press the center of + and if the 5 coordonates were been set correctly it will pass at sound test, or it will return at the calibrating screen .
  6. If you executed correctly the steps and you arrived at “Sound Test”, turn off and then turn on the GPS.
  7. Assure that you executed correctly the procedure and if the problem persist, contact our service.

Try that or use one of the hidden secret Android codes to get at the service menu, there may be an option in there to calibrate the touchscreen?

  • The instructions are for GPS devices with resistive screens, running windows CE. I would try the service code thing but don't know how to start the dialer on a tablet. I can see it's installed but can't find it in the app drawer... Thanks! – user25485 Dec 27 '12 at 21:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.