I have a Galaxy S3, screen is visually and touch impaired. It is USB debug enabled, un-rooted.

I'm able to use Droid@Screen to see my screen, which i'm able to unlock. I then run this command:

adb backup –apk –shared –all –f /backup/mybackup.ab

Which then initiates a backup on the phone. On the screen I can see it asking for an encryption password, which i provide by keyevent through adb. The final sticking point, is being unable to find a keyevent which will press the "Backup up my data" button. I am able to tab to it, and have it highlighted, but the 'space' and 'enter' events do not trigger it, as well as 'soft_right'.

I'm getting my keyevents from HERE.

]![Backup Scr][2

If there is another way for me to dump the ab, that would be awesome.

  • Am surprised that Droid@Screen does not have a mouse to interact with it such as remote vnc... :o what other key events have you tried? BTW, can you recall what hardware key sits underneath directly the input soft button labelled "Backup my data"? Maybe it needs keycode_focus first then keycode_enter?
    – t0mm13b
    Dec 27, 2012 at 19:46
  • There isn't a hardware key under that.
    – DanBig
    Dec 27, 2012 at 20:34

3 Answers 3


I was in the same situation as you. Once you enter the full backup screen Use the following commands:

adb shell input text <your password>
adb shell input keyevent 22
adb shell input keyevent 23

the "adb shell input keyevent 22" command is Dpad Right, you'll be able to select back up my data the "adb shell input keyevent 23" is the Dpad Center, It will allow you to select enter




Have you tried sending a KEYCODE_DPAD_CENTER?

adb shell input keyevent 23
  • That moves the focus off the target, but does not appear to work either.
    – DanBig
    Dec 27, 2012 at 19:26

Use Droid Explorer and the Screencast plugin to use your keyboard and mouse from your desktop computer to control the handset?

That would make life easier instead of fiddling around with using adb shell input keyevent ...

  • I'm not rooted, so screencast isn't going to work, correct?
    – DanBig
    Dec 27, 2012 at 20:36
  • I confirm you do not need to be rooted, however, it is pretty limited, but maybe that's because the handset used in conjunction with screencast, is eclair 2.1...
    – t0mm13b
    Dec 27, 2012 at 21:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .