My stepmother has a Kindle Fire. I want to install the Amazon Free app of the day (from link here): http://www.amazon.com/gp/feature.html?ie=UTF8&docId=1000626391

I go to link, download the file, and it comes up with the .apk. I install it, and click "OPEN". When the installation is done, it takes me back to the web page to download it.

I enabled it to allow to install 3rd party apps. The Amazon account is setup with a debit card and onclick is enabled.

If I go to manage my Apps and view all apps, the icon shows up twice. But there is no uninstall button to click; it is grayed out.

I have done this on 3 phones and 1 other kindle fire, and had no problems.

Anyone have any ideas?

  • The link you've provided is for the Amazon Appstore itself, so that it can be installed on Android devices (thereby giving them access to the Appstore). The Kindle Fire comes with this pre-installed (the "Apps" link on the top bar of the home screen). Why are you attempting to install it like this? – eldarerathis Dec 27 '12 at 16:25
  • Sorry I was following the directions on this page to download the app that is at this link: amazon.com/gp/mas/get/android/ref=mas_mbl_ldg She has the amazon store on her kindle but not the app store, I did this before on my babysitters and it worked fine, it is the orange icon with appstore on it – Brad Dec 27 '12 at 16:29
  • She has the amazon store on her kindle but not the app store - Unless the Fire has been modified, this is...impossible. What you're attempting to do quite frankly just doesn't make sense. The Kindle Fire comes with the Appstore pre-installed. Just tap on the "Apps" link on the top bar of the home screen and there should be a "Store" link on the next page. That's all you need; it's the exact same store. – eldarerathis Dec 27 '12 at 16:32
  • on our babysitters Kindle Fire I was able to get the app to the appstore (the orange icon) to show up as an icon on her "desktop" so she could just click it and go directly to android apps, with the free app of the day showing up on the top. – Brad Dec 27 '12 at 16:35
  • Again, though - why would you need to do this? The fact that it worked at all in the past seems like it could be a total anomaly since it is almost certainly not designed to be installed (essentially) on top of itself. Why not just use the built-in interface the way it was intended? Can you not get the free app that way? It has always worked for me. This seems like it's going down the path of an XY problem. – eldarerathis Dec 27 '12 at 16:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.