1

Possible Duplicate:
Cannot unlock tablet as have no internet connection?

Just now my android phone ( HTC Desire S ) got locked ( apparently my nephew tried the unlock pattern hell lot of time :( ). Now it is asking for userID and password. This is not the first time it happened. But earlier I used to supply my userID/pass ( same userID/pass which I use for stackexchange ) and it always worked. But this time when I tried the same id/pass combination it didn't worked. Although I can login using those credentials to my gmail account.( that means password is not changed ).

After doing the quick google I got to know that I will have to do factory reset, which I really don't want to do. Please help what can I do.

My phone is on Android 4.0 if that matters.

5
  • Do you have 2-step authentication enabled on your Google Account? – t0mm13b Dec 28 '12 at 17:53
  • I guess yes once I did that. Is there a way to confirm that? – Rakesh Juyal Dec 28 '12 at 17:54
  • Go into your Google Account Settings from your PC, under Account & Import > Change Account settings > Other Google Account settings there should be a setting similar to "Enable 2-step authentication"? – t0mm13b Dec 28 '12 at 17:57
  • Ok so it says Status: OFF; that means 2 step verification is not ON. now what? can we come on chat? – Rakesh Juyal Dec 28 '12 at 18:09
  • 1
    I have ran into this problem before and I have 2-Step verification enabled. I am able to simply enter my credentials into my phone and it unlocks. – Jared Burrows Dec 28 '12 at 20:45