I previously used Ubuntu 12.04. When I connected my phone (Sony Xperia U) in MTP mode, I would be able to see it in Nautilus as a "SEMC HSUSB device" and browse files, copy files, and so on.

Now, I have a new laptop and I've installed Ubuntu 12.10 on it. My device is not recognised any more by Nautilus - I can see that the OS recognises it by seeing the entries that appear in /var/log/syslog - but the phone does not get mounted and I can't think of any way to access the files on the phone and put new files there except the terribly slow Bluetooth.

Has anyone else faced such an issue? Can you help?

  • 2
    Did you see this thread on XDA?
    – Sid
    Commented Dec 29, 2012 at 9:08
  • My first thought was "some missing udev rule", and that XDA post exactly mentions this. @Sid -- would you mind putting that into an answer, with a short abstract from the XDA post? I'd say that's exactly the answer to this question.
    – Izzy
    Commented Dec 29, 2012 at 13:40
  • @Izzy Done. Please have a look :D
    – Sid
    Commented Dec 29, 2012 at 14:40
  • @Sid Yupp, excellent -- +1 from me :D
    – Izzy
    Commented Dec 29, 2012 at 14:50
  • Hi, I commented on your answer. Commented Jan 6, 2013 at 9:12

4 Answers 4


I have found the simplest method, with both my Samsung Galaxy Tab2 7.0 tablet and Galaxy S3 Mini smartphone, is to use SSHDroid (on the Android device) to provide SSH server.

Google play > SSHDroid by Berserker

Then I simply connect from Nautilus using SSH, over WiFi. This is plenty fast and I can bookmark the links for re-use (provided the IP address stays static). After first use, I simply set a static IP on my router for those MAC addresses.

I have also used a terminal, for an SSH command line session to the devices. This also just uses the SSHDroid service.


Yyou can choose another connection mode, mass storage mode, this way, it will be auto detected when you connect the USB cable. The option to change the connection mode is in:

Setting -> Xperia -> Connectivity -> USB Connection mode
  • On Android 5.1.1 Xperia Z3 it is now: Settings > Xperia Connectivity > USB connectivity. And it only works for SSD cards, not internal storage. Commented Nov 30, 2015 at 10:53

After upgrading my Xperia U to ICS Linux Mint Maya no longer recognised the device as you have listed SEMC HSUSB device. For some reason the MTP support has changed and there is no longer the option to drag and drop.

Instead use either 'qlix' or 'gmtp' from the usual repos. My preference is for qlix.

  • Plug in the phone and start qlix and leave it for a few minutes. Eventually it WILL recognise the Xperia U.
  • Click on view files the left pane is your desktop file system, the right pane is the android file system.

It's then a simple matter of opening the correct folder on both sides and right clicking files to transfer.

The initial mounting of the device is slow but the transfer of files thereafter is fast and, because it is using MTP, the rest of your file system remains safe from corruption.

No longer any need to unmount the device.

  • Thanks mate, but I tried installing qlix, and that hasn't been able to detect the phone either, neither has gmtp (both returning errors saying they couldn't detect the device.) Additionally, once every few times when I plug my phone in to charge it (without using either qlix or gmtp), I get a pop-up message saying the SEMC HSUSB device couldn't be detected. In short - still stuck. Commented Jan 31, 2013 at 9:40
  • I'm not an expert but on my machine I get the same error messages that you do. MTP support is very sketchy between android and Linux which is the odd given they are both a linux system. Commented Feb 2, 2013 at 20:22
  • @airbornemihir With qlix you just have to wait and wait until it connects - if that isn't working for you then with gmtp you have to wait even longer for it to connect. it throws up error messages about no devices. just click connect and leave it alone for five minutes. don t click any other gui buttons otherwise it always crashes. mtp support is terrible re android but maybe i'm lucky - try using a linux mint live cd and see if you can get it to work with that, I'm using the 'mate' DE Commented Feb 2, 2013 at 20:37
  • Thanks, Kevin! For me qlix just churned for a while before it died. But gmtp was fast, simple and successful. Using Kubuntu-12.10 and Xperia Ray. Commented Mar 6, 2013 at 20:34

Following steps will guide you through.

  1. Connect your phone to the laptop and list your devices in a terminal using lsusb command

  2. Find a line similar to Bus 002 Device 012: ID 0fce:5169 Sony Ericsson Mobile Communications AB and note your vendor and product id which are 0fce and 5169 respectively in the above line. If you have USB debugging disabled, product id will be 0169. Now Unplug the phone.

  3. Go to humans-enabled.com and install the latest version of libmtp and copy the 69-libmtp.rules file to /etc/udev/rules.d as described

  4. Optional step

    Xperia S support is implemented in the libmtp-1.1.3 release. If you use the latest version from sourceforge.net, skip to step 5.

    type sudo gedit /etc/udev/rules.d/69-libmtp.rules to edit the copied file as root.

    Add the following text somewhere around the sony ericsson devices in this file. You can find them by searching for 0fce. Remember to set the correct vendor and product id

    ATTR{idVendor}=="0fce", ATTR{idProduct}=="5169", SYMLINK+="libmtp-%k", ENV{ID_MTP_DEVICE}="1", ENV{ID_MEDIA_PLAYER}="1" ATTR{idVendor}=="0fce", ATTR{idProduct}=="0169", SYMLINK+="libmtp-%k", ENV{ID_MTP_DEVICE}="1", ENV{ID_MEDIA_PLAYER}="1"

  5. reboot, or use sudo udevadm control --reload-rules to actualize.

  6. The phone will mount automatically when you plug it. Use nautilus to copy files

See this for more info

  • Is this (particularly udev syntax) for Ubuntu 11.x, or latest (12.10) ?
    – david6
    Commented Dec 29, 2012 at 23:08
  • 1
    Thanks. I followed the steps you suggested, with one modification: I downloaded Ubuntu's raring package for libmtp, which gave me version 1.1.5 corresponding the latest from sourceforge. The product ID in my case were 5171 and 0171 instead of those you suggested. I copied these into the /etc/rules.d/70-libmtp.rules file (this is an empty file which is supposed to override /lib/udev/rules.d/69-libmtp.rules) and ran sudo udevadm control --reload-rules. Still no success. Commented Jan 3, 2013 at 12:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .