Whenever I try to download an app in the Google Play Store on my Samsung Galaxy S3, it keeps saying "package file invalid" and won't let me download anything. The message also has a triangle with a ! inside it.

  • 1
    @geffchang Since that question is a temporary fault first observed on the 7th of this month, it's unlikely to be the same issue that the OP saw in January. – Dan Hulme Aug 17 '13 at 14:46
  • @DanHulme I thought about that later too. Retracted my Close Vote. – geffchang Aug 17 '13 at 14:47
  • This is likely a temporary problem on the server side. And if this is the case, then there is nothing a user could do. – Flow Sep 17 '13 at 14:34

Try downloading via WIFI.

I had this issue recently, same phone. Tried a few times; both on PC and on the device itself each failed. I realized WiFi was off (mobile data only). I turned WiFi on and the file downloaded first go.

| improve this answer | |
  1. Log into Google Play Store (via browser)
  2. Scroll to the bottom of the page & Locate "My Orders & Settings"
  3. Click on the Settings Tab
  4. Assign a "Nickname" to your phone
  5. Check "Shown in Menus"
  6. Save settings
  7. Return to the Play Store and download Apps.

This worked for me.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.