Without using a market app, how can I set a custom MP3 file as ringtone?
I've tried placing the MP3 in media/audio/ringtones and variations (e.g. media/ringtones), but the MP3 does not show in Settings->Sound->Ringtone.

Thank you.


4 Answers 4


I placed mine in /sdcard/media/audio/ringtones. After that the sound appears in the settings menu.

See also: How do I set a custom MP3 as a ringtone for other notifications?

  • Folder names are case-sensitive?
    – Francisc
    Commented Jan 3, 2013 at 2:31
  • Yup, folder names are case-sensitive. Thank you.
    – Francisc
    Commented Jan 3, 2013 at 2:37
  • There's no such thing as "Set as Ringtone" from music app, is there?
    – Francisc
    Commented Jan 3, 2013 at 2:38
  • He asked how to do it without such an app. Commented Jan 3, 2013 at 6:32
  • I am he. :) There was a "Set as" from the default music player that came with the original Samsung-branded OS.
    – Francisc
    Commented Jan 3, 2013 at 14:52

I had the same issue and recently found a perfect solution by accident. While viewing the playlist that contains the song you wish to use as a ringtone (on the apollo media player),a longpress on the song you want to use will give you a list of options; among that list will be "use as ringtone". Simply select, and enjoy your new ringtone! This only works for call ringtones, for message tones you will need another fix. Hope this helps. Works on samsung galaxy S running Cyanogen Mod 10.1 RC5.


I had the same error on Froyo and Gingerbread roms and i found a solution:

  • Put your sounds into /system/media/audio/ringtones
  • Clear cache from recovery
  • 2
    This might work as I read it from other sources too, but it means every time you flash a new ROM the ringtones will be lost.
    – Lex Li
    Commented Jun 17, 2013 at 2:39

What worked for me was to add it to the sdcard ringtones directory (if not there, create it), copy the file manually to that directory and then reboot. Before the reboot the file did not show up in my Cyanomod 7.2 Cooper (Samsung S5380), but it did after the reboot. The file I copied was a mp3 file. I hope this solution works too for other mods.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .