Running Android 2.3.4 System Version 5.9.905.XT875

I rooted my Droid Bionic using SuperOneClick. Stupidly, I didn't backup my ROM at any point before beginning to tinker with it.

The only thing I did that required root access was freeze and delete some bloatware using Root Uninstaller. Every program that I froze or deleted, I first backed up. When an Android update (don't remember which one) was made available and I let it download and install, it simply said "The software update failed!" after rebooting. I went back to unfreeze/install every system app so that the phone was back to it's state before using Root Uninstaller, but two apps won't reinstall. Those apps are "SmartCarDock" and "Social Networking" (The APK is called FriendFeed). When I run the APK for each program, it just says "Application not installed". From what I've gathered from searching, my best guess is that it could be something to do with saved userdata that is preventing the system from installing an app that "should" be installed, but I have no idea where to start.

I also am unable to unroot, presumably because of those two apps.

I know this could have been prevented by backing up the ROM, but, well, I made a mistake.

In general, I am asking because I want to update my Bionic to ICS, so if anyone has answers pertaining to that, all is helpful.

Let me know if more details are needed!

  • 1
    A factory reset might work, although it might not restore the missing apps either. You could backup the backups somewhere off the device and try it, then try to reinstall the apps if they haven't shown up at that point. Is your bootloader locked? – Matthew Read Jan 2 '13 at 20:57
  • @MatthewRead When I boot into recovery, it just shows an android with an exclamation point. In the past, I tried installing from my computer, and it still didn't work. – Wilson Jan 2 '13 at 21:21
  • That's Download Mode, not Recovery Mode. You may need to use a different key combination to get there (from an off state of from the former mode). – Matthew Read Jan 2 '13 at 21:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.