I am facing an application can not be installed error on my Samsaung Galaxy S Plus whenever I try to install applications. I have already allowed installation from unknown sources, but it didn't work. It still have a lot of memory space although my phone has no SD card.

Can you suggest some solutions to solve this? Thanks in advance.

  • Have you already restarted your phone since you got this error?
    – ndsmyter
    Jan 3, 2013 at 9:17
  • 1
    And what is the complete error message? Is there more to it than just "cannot", maybe some reason given?
    – Izzy
    Jan 3, 2013 at 10:09
  • If your locale and UI language on the phone is not set to english, change it to english and try again.
    – yrajabi
    Jan 3, 2013 at 10:27
  • 1
    Did you see this?
    – Sid
    Jan 3, 2013 at 14:38

4 Answers 4


First, make sure you have sufficient internal memory (that should be more than just the app size, because app needs to store data too). The storage for apps is different from internal mass storage. You can find it under Settings > Storage, look for the Applications label.

Also, if the app is, say 20 MB, keep at least 50 MB free, because apart from the app storage, Android also tends to slow down when short on internal memory.

If you're trying to update/overwrite an installed app, try removing it first. source.

If that didn't work, try this solution. It is aimed at Titanium Backup, but I guess it might work for other apps too.


There might be mainly these two possibilities 1) either the device didn't have the sufficient memory 2) ADB Connection Time out error

To solve 1) clear you temporary memory, un install application or clear un wanted cache 2) go to preferences->Android->DDMS and increase you ADB connection time out according to your need mine is 11000


That happened to me when I was trying to test on a real device an unsigned app that I built, maybe that's the case.

If you're a developer, sign the app before testing it.

  • I'm getting Minecraft:Pocket Edition can't be installed on USB storage or SD card. ...Error code -18. While upgrading the installed version from Google Play. Samsung tablet, Android 4.4.2. More than 2G of memory available, uninstalled, rebooted, cleared cache,prayed to moon.. My kid is upset, appreciate any help!
    – Dmitry z
    Jun 17, 2016 at 1:32

i had same error on my HUAWEI phone and it solved when I changed Default install Location on SD card.

  • 1
    Thanks for sharing, bijan! Could you please clarify: Did you change that settings so apps get installed on SD card now, or the other way around?
    – Izzy
    Nov 4, 2014 at 14:59

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .