Just got a nexus 4, and tried to copy files from my nexus one to it. Copying the N1 SD data to my linux box was a breeze, but the N4 doesn't offer simple mounting. Shows up as a USB Camera, with only access to DCIM. I was able to find and use mtpfs to mount the device, but even that has some serious limitations.

  1. The software on the phone's end seems to make some decisions for you. I tried copying a mix of files from the N1's Ringtones directory to a Ringtones directory on the N4, and the N4 decided that mp3's belong in the Music directory, etc. I couldn't control where stuff went. Interesting, some flv files that were there went to Ringones, but not the mp3's. At first I thought the mp3's weren't copied at all. I was able to fool this logic by copying to Download on the N4. Anyway, not sure I like the phone making these decisions.

  2. The mtpfs mount didn't allow me to preserve the timestamps on the copied files. I copied a bunch of pictures (cp -p) from the N1's DCIM/Camera folder to the N4's. They all came over with the current date/time. I can see where it'd be a good idea not to allow a usb mount to set the owner or permissions for a file, but the timestamp? Is there a way around this, or is this just a shortcoming of the linux mtpfs implementation?

  • 1
    One more MTP question... In 4.2 multi-user mode, does MTP only mount the current user's storage area? And does it force ownership of all written files to that user? How about if your phone's rooted? – littlenoodles Jan 3 '13 at 16:29
  • This has to be a limitation on linux, because in windows I see the entire internal storage and the entire sdcard for my device. Also, I am not sure what question you are actually asking. – Ryan Conrad Jan 3 '13 at 16:46
  • With mtpfs I see what appears to be the entire internal storage, though it turns out that, for example, what shows up as /DCIM is really /storage/o/DCIM (or something like that). That's good, since it seems to be showing only the current user's internal storage (and not the OS itself). But my questions remain - I can write (where I can write), but I can't set the timestamp on files I write. – littlenoodles Jan 3 '13 at 17:58
  • The timestamp issue should be raised as a separate question. It is mostly the old 'push' / 'pull' problem, with the recipient host not honouring the (remote) timestamp. This can be circumvented by copying 'from', instead of 'to', the target location. – david6 Jan 3 '13 at 21:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.