Device: Motorola RAZR (XT910) MAXX

I downloaded a battery mod (percentage display, which replaces the stock icon on status bar) which has 2 main files: services.jar and SystemUI.apk, and all the deodexed system apps and framework files.

I followed all the instructions, which asked me to replace all the system apks with the decodexed ones, and then replace the 2 main files. It worked.

But I heard that with odex files, apps run faster because they are cached (or whatever it should be called). So, I tried to replace only the 2 main files. Now, the whole system just hangs when it boots, even when I restored the originals. Q1: Why is this so?

Q2: What files should I also replace to get this to work? framework.jar? framework-ext.jar? com.motorola.android.frameworks.jar?

update (solved)

Sorry guys, it was my bad. This time I just simply deleted SystemUI.odex, replaced SystemUI.apk with Root Explorer, changed permission, and it worked fine. The instructions I followed before might not just for the battery mod, but for replacing all files with non-odexed files.

  • Did you wipe just the cache only? – t0mm13b Jan 5 '13 at 16:13
  • Either answer your own question (which is perfectly fine) or just delete the question. – Flow Jan 5 '13 at 18:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.