I'm trying to develop applications that talk to USB devices, but nothing works. I installed a USB Host Diagnostics app, and it tells me that there's no OS support for device detection on the Galaxy Nexus or the Nexus 10. I'm running Android 4.2 on both.

I tried the AdbTest sample application, but that doesn't respond when I connect the devices together. I tried updating the files in /system/etc/permissions as discussed here, but that doesn't do anything.

Can anyone get USB device detection to work on these devices? Thanks!

1 Answer 1


I don't know the specifics about n10, but I found out an issue with my n7. When I bought it I got USB OTG/host working, but now when I tried with 4.2 it does not work anymore!

I found out that it was configured incorrectly. If you check /etc/permissions/tablet_core_hardware.xml you should see line android.hardware.usb.host in there, but after 4.2 upgrade it was not there anymore.

So for me it looks like the only way to get it working is to root the device. :-( I wonder why it has been taken out.

  • I have a Nexus 7 running 4.2.2. It is rooted mainly for USB OTG usage, which I am using quite well. Being curious about the XML, I could not find any entry related to host or USB in that file, but still OTG works.
    – Narayanan
    Jul 7, 2013 at 3:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .