I'm running the CM10.1 nightlies on my Galaxy S2 (i9100). I've purchased the KitSound GALS2Dock, which has audio out over USB, but it doesn't work.

I've asked KitSound via Twitter, and they told me to switch on the Audio Output Mode. I think this is a Samsung specific setting, but I found this in the samsung specific CM10.1 settings menu.

The CM settings menu (It says USB-audio dock - use passive audio out from the dock)

I've checked it, and now the phone audio stops (so that's one thing) but my box nor my TV recognises the sound. It does work when I plug it in the regular audio jack.

So I'm thinking this is a software issue. My question: where could this issue be? Is it CM10.1? Is it CM in general (EG: downgrading to CM10 wouldn't help? Or do I need to switch back to a stock samsung ROM in it's entirety to have this functionality work (I'd prefer not to).

Any ideas?


3 Answers 3


I know that this has been fixed in some of the latest CM10 nightly releases. As a matter of fact, I'm running JellyBam 4.1 (based on CM10) and the USB audio does work without issues. When I've updated to JellyBam 5.2 (based on CM10.1), USB audio stopped working. So I had to revert back to 4.1, which is, in my opinion, an excellent release anyway.

I've read in forums that the problem is not proprietary drivers or anything like that (it is working on CM10 nightlys afterall), but rather than CM team has not finished implementing all audio features on 10.1 yet. The need to migrate this patch to CM10.1, that's all.

So my advice is to install CM10 nightly or JellyBam 4.1. You will enjoy Android 4.1.2, and of course, your USB audio.

  • That's great to hear though, because that means that in a later stadium, I'll probably be able to enjoy the audio out on 4.2 or maybe even 5.0 by that time :) Thanks!
    – Vic V
    Feb 17, 2013 at 15:10

I had this working on CM10 by un-checking this box, and using an app called dock audio switcher. It would detect the dock and automatically change the audio output through the USB.

However, I have tried using this on CM10.1, and this app no longer works. I've also tried using the USB passive audio setting in the advanced menu, and this also no longer works.

The odd thing is when I use the USB passive audio I get no sound whatsoever, but when I use the dock audio switcher I can hear a bump from the speakers, similar to when you first plug a audio cable into the phone jack.

So it seems that its activating the audio to USB, but it just cant push it over.

  • Dock Audio Switcher is an apple app right?
    – t0mm13b
    Jan 28, 2013 at 15:39
  • Sad days. I hope a developer picks this up soon, because it's a pretty nifty feature! I'm no fan of Samsung's software, but they nailed this. Thanks for the feedback though!
    – Vic V
    Jan 29, 2013 at 13:54

Downgrading to the leaked 4.1 (official) firmware fixes the problem. I'll update this answer if I find out if it works on CM10.

  • It would be proprietary drivers then ;)
    – Liam W
    Jan 14, 2013 at 8:22
  • Yeah, I guess you're right. I'm pretty sure the setting above is the right one though. Usually, when the CM team creates stuff, they somehow find workarounds! I hope they will, because I don't like TouchWizz.
    – Vic V
    Jan 14, 2013 at 10:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .